Artikel ohne Artikelbild Standard/Musterbild zuweisen?

Thema wurde von tom_stockhusen, 15. April 2021 erstellt.

  1. tom_stockhusen

    tom_stockhusen Mitglied

    Registriert seit:
    11. September 2020
    Beiträge:
    11
    Danke erhalten:
    0
    Danke vergeben:
    1
    Guten Morgen,

    besteht die Möglichkeit bei Artikeln, die keine Bilder haben oder ein hinterlegtes Foto, welches nicht angezeigt werden kann ,da es ggf. auf dem FTP fehlt, ein Standard Foto einzublenden?

    Wir haben weit über 20.000 Artikel im Shop und haben daher einige "Leichen" wo fälschlicherweise keine Fotos angezeigt werden oder wo noch nichts eingepflegt ist.

    Dafür würde ich gerne ein Musterbild einpflegen "Coming soon" und unser Firmenlogo, so was in der Richtung.

    Ist so etwas schnell umsetzbar oder in mühevoller Zeit zu erledigen?

    Vielen Dank!

    MfG
     
  2. FRAGO

    FRAGO Erfahrener Benutzer

    Registriert seit:
    5. Dezember 2019
    Beiträge:
    778
    Danke erhalten:
    242
    Danke vergeben:
    99
    Das Musterbild ist ja eigentlich kein Bild, es ist ein Font Awesome Symbol. Des Weiteren wird dies ja nur in den Übersichten angezeigt, im Artikel wird ja, wenn kein Bild eingestellt wurde, nichts angezeigt.

    Ohne Code Anpassung wird das wohl nicht funktionieren. Da die Frage schon mehrfach auftauchte, versuch es einfach mal mit der Forum-Suche...
     
  3. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    28. Dezember 2020
    Beiträge:
    130
    Danke erhalten:
    52
    Danke vergeben:
    12
    Wenn du was von smarty-Block überladen verstehst, kann man da Anpassungen erstellen.
    z.B. für die product_info_gallery_main.html (ungetestet)
    HTML:
        {block name="product_info_gallery_image"}
            <div class="product-info-image {if 'SHOW_ZOOM'|gm_get_conf === 'true'}has-zoom{/if}" {if 'SHOW_ZOOM'|gm_get_conf === 'true'}data-gambio-widget="{if 'GALLERY_LIGHTBOX'|gm_get_conf === 'true'}image_gallery_lightbox{else}image_gallery{/if} magnifier" data-magnifier-target=".magnifier-target"{else}data-gambio-widget="{if 'GALLERY_LIGHTBOX'|gm_get_conf === 'true'}image_gallery_lightbox{else}image_gallery{/if}"{/if}>
                <div class="product-info-image-inside">
                    {include file="get_usermod:{$tpl_path}product_info_gallery_swiper.html" swiperId="product_image_swiper" startWidget="true" swiperImages=$images swiperControls="#product_thumbnail_swiper, #product_thumbnail_swiper_mobile" swiperOptions=", \"effect\": \"fade\", \"autoplay\": null"}
                </div>
                <input type="hidden" id="current-gallery-hash" value="{$hash}">
            </div>
    {else}
    <div class="product-info-image>
    <img class="img-responsive" src="images/Platzhalter/Platzhalter.JPG" alt="Leider kein Bild vorhanden" title="Leider kein Bild vorhanden">
    </div>
        {/block}
    Bitte erst im Testshop ausprobieren.