Bei "Weiter zur Kasse" unvermittelt WK leer!

Thema wurde von Manni_HB, 10. Dezember 2013 erstellt.

  1. Petra

    Petra G-WARD 2013/14/15

    Registriert seit:
    27. August 2011
    Beiträge:
    6.998
    Danke erhalten:
    1.219
    Danke vergeben:
    227
    Upps. :) Aber das mit dem Caching hört sich schon plausibel an, ich bin gespannt. Was mich nur wundert: ein paar Tage ging es gut, dann fing der Zauber wieder an.
     
  2. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    13. Juni 2011
    Beiträge:
    693
    Danke erhalten:
    138
    Danke vergeben:
    137
    zur Petras Frage bzgl. Provider: ich bin bei einem Kleinen (webhost.at) - hab hier aber alle Rechte und Unterstützung - dh. das hier die Ursache ist, schließe ich zu 99% aus.

    Ich hab euch ja geschrieben, dass das Problem nur bei einem unserer PC+s auftritt - denkste :) , jetzt tritt das Problem auch beim Anderen auf. :( - und wie gesagt, auch ein IE11

    Ich habe in meiner .htaccess folgendes drinnen gehabt: php_value session.gc_maxlifetime 3600
    Hab das mal entfernt und teste und beobachte mal weiter...
     
  3. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    13. Juni 2011
    Beiträge:
    693
    Danke erhalten:
    138
    Danke vergeben:
    137
    Gut, ich kann weiter als Gast NICHT bestellen!

    Wenn ich als Admin eingeloggt war, eine Bestellung ausführe, dann muss ich mich neu einloggen und kann dann zumindest bestellen. Das geht meistens, aber nicht immer.
     
  4. Manni_HB

    Manni_HB G-WARD 2012/13/14/15

    Registriert seit:
    26. April 2011
    Beiträge:
    9.098
    Danke erhalten:
    1.539
    Danke vergeben:
    908
    Ort:
    Bremen
    "whos_online" wirklich zuverlässig?

    Neue Variante:

    In "whos_online" sehe wie ein eingeloggter Kunden munter den WK füllt - fein!
    Plötzlich: Kein WK mehr, keine Anzeige des KD-Namen, keine Bestellung - Upps.

    Direkt darunter habe ich eine PiWik-Anzeige laufen.
    Nanu ... da ist er ja noch und macht fleissig weiter ... und oben in "whos-online" => NIX. Ich sehe zwar die Seiten, die er aufruft, aber keinen gefüllten WK!

    Der grüne Kringel zeigt ungefähr den Zeitpunkt an, ab dem der WK im "whos_online" verschwand.
    Auch beide "Online-Zeiten" weichen deutlich von einander ab!

    Ich für meinen Teil traue der Anzeige in "whos_online" nicht besonders über den Weg.
    Manch plötzlich verschwundener WK könnte sich m.E. auch hiermit erklären.
     

    Anhänge:

  5. Avenger

    Avenger G-WARD 2012/13/14/15

    Registriert seit:
    26. April 2011
    Beiträge:
    4.771
    Danke erhalten:
    1.478
    Danke vergeben:
    89
    Das ist aber nur damit zu erklären, dass die Session geändert wurde....

    Ist die IP gleich geblieben?

    Sagt das Logging etwas dazu?
     
  6. Manni_HB

    Manni_HB G-WARD 2012/13/14/15

    Registriert seit:
    26. April 2011
    Beiträge:
    9.098
    Danke erhalten:
    1.539
    Danke vergeben:
    908
    Ort:
    Bremen
    IP gleich geblieben, Logfile leer.
     
  7. Petra

    Petra G-WARD 2013/14/15

    Registriert seit:
    27. August 2011
    Beiträge:
    6.998
    Danke erhalten:
    1.219
    Danke vergeben:
    227
    Bei uns ist das Logfile übrigens auch leer. Und ich habe das Phänomen aus Piwik. Dort kann ich ja sehen, wie die Leute klicken und im Checkout hängenbleiben, wieder zurück gehen usw. Was übrigens auch sehr merkwürdig ist, dass man manche IPs im Piwik überhaupt nicht findet.
     
  8. Anonymous

    Anonymous G-WARD 2015/2016

    Registriert seit:
    20. Februar 2012
    Beiträge:
    8.583
    Danke erhalten:
    1.484
    Danke vergeben:
    962
    Ist mir auch schon augefallen!
     
  9. Dennis (MotivMonster.de)

    Dennis (MotivMonster.de) G-WARD 2013/14/15/16

    Registriert seit:
    22. September 2011
    Beiträge:
    30.477
    Danke erhalten:
    5.932
    Danke vergeben:
    1.061
    Beruf:
    Mann für alles :)
    Ort:
    Weilburg
    ja weil - no track im Browser des Users aktiviert wurde :) - z.b. im neusten InternetDoof autom. oft so aktiv.
     
  10. Manni_HB

    Manni_HB G-WARD 2012/13/14/15

    Registriert seit:
    26. April 2011
    Beiträge:
    9.098
    Danke erhalten:
    1.539
    Danke vergeben:
    908
    Ort:
    Bremen
    #150 Manni_HB, 31. Januar 2014
    Zuletzt bearbeitet: 31. Januar 2014
    Oder in den Datenschutzbestimmungen der Haken entfernt wurde beim PiwikZeuch. :)
     
  11. Petra

    Petra G-WARD 2013/14/15

    Registriert seit:
    27. August 2011
    Beiträge:
    6.998
    Danke erhalten:
    1.219
    Danke vergeben:
    227
    Stimmt, da war ja was ;)
     
  12. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    13. Juni 2011
    Beiträge:
    693
    Danke erhalten:
    138
    Danke vergeben:
    137
    Hat sich bei auch nach dem Update auf 2.0.14.3 irgendwas verändert? - Ich kann weiterhin mit dem IE11 nicht bestellen.
     
  13. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.394
    Danke erhalten:
    2.431
    Danke vergeben:
    783
    Hallo,

    hast du den Seitencache und Browsercache geleert? Nutzt du das Standardtemplate?
     
  14. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    13. Juni 2011
    Beiträge:
    693
    Danke erhalten:
    138
    Danke vergeben:
    137
    Ja, hab ich, und ich benutze das Standardtemplate.

    PS: nicht vergessen, mit allen anderen Browsern besteht für mich das Problem nicht - nur IE11 muckt, und dass nicht immer schon. - keine Ahnung, wann es begonnen hat (so oft bestellt man ja nicht bei sich selbst :) )
     
  15. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.394
    Danke erhalten:
    2.431
    Danke vergeben:
    783
    In diesem Fall rate ich dir dich an den Support zu wenden mit der Bitte das Ticket an mich weiterleiten zu lassen. Das muss analysiert werden und kann nicht aus dem Stegreif gelöst werden.
     
  16. Daniela

    Daniela Erfahrener Benutzer

    Registriert seit:
    28. Oktober 2011
    Beiträge:
    788
    Danke erhalten:
    142
    Danke vergeben:
    109
    Und ich hab hier auch was schönes.
    Artikel im Warenkorb mit € 0,00
    Nein, der Artikel ist nicht kostenlos, im Artikel steht ein Preis drin.
    Und dann noch eine Suchanfrage mit "Warenkorb falsch".
    Was soll mir das jetzt sagen?
     

    Anhänge:

  17. Manni_HB

    Manni_HB G-WARD 2012/13/14/15

    Registriert seit:
    26. April 2011
    Beiträge:
    9.098
    Danke erhalten:
    1.539
    Danke vergeben:
    908
    Ort:
    Bremen
    Dass Du nicht alleine bist! :) Beobachte ich seit ewigen Zeiten! :(
    Wie ich schon sagte, das "whos_online" ist mit äußerster Vorsicht zu beobachten!!!
     
  18. Petra

    Petra G-WARD 2013/14/15

    Registriert seit:
    27. August 2011
    Beiträge:
    6.998
    Danke erhalten:
    1.219
    Danke vergeben:
    227
    Stimmt, das haben wir auch häufig und es ist meist dann, wenn sich die Kunden gerade einloggen. Kurz danach sieht man dann nämlich den Kundennamen. Warenkorb ist dann für kurze Zeit noch auf 0, beim nächsten Refresh sieht man aber die Preise. "Warenkorn falsch" hatte ich allerdings noch nicht.
     
  19. Petra

    Petra G-WARD 2013/14/15

    Registriert seit:
    27. August 2011
    Beiträge:
    6.998
    Danke erhalten:
    1.219
    Danke vergeben:
    227
    So langsam aber sicher habe ich wirklich die Nase voll. Das Phänomen tritt immer noch auf und auch das, dass sich Kunden anmelden und dennoch kein Kundenkonto erstellt wird, bzw. sich gar nicht erst anmelden können. Das habe ich gerade live erlebt und kurz darauf folgende Nachricht erhalten:

    Ich habe die Kundin beobachtet, wieder hing sie im Checkout, war vorher und nachher im Login, das Kundenkonto wurde nicht angelegt, die Bestellung auch nicht, weil ging ja nicht.
     
  20. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.745
    Danke erhalten:
    10.499
    Danke vergeben:
    1.500
    Weist Du wie die Kundin in Deinen Shop kam?