customers_status_id is nicht korrekt gesetzt, ajax geht nicht

Thema wurde von jann_brand, 27. Januar 2020 erstellt.

  1. jann_brand

    jann_brand Aktives Mitglied

    Registriert seit:
    17. Januar 2020
    Beiträge:
    35
    Danke erhalten:
    0
    Hallo zusammen

    ich muss in der

    GXMainComponents/Services/System/Http/AdminHttpViewController.inc.php

    die exception auskommentieren, da sonst die ajax Requests im backend nicht funktionieren.

    Die $_SESSION['customers_status']['customers_status_id'] ist bei mir nach Login im Backend 0. Wie kann ich damit umgehen um nicht eine Sicherheitslücke zu öffnen?

    Danke und viele Grüsse
     
  2. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.744
    Danke erhalten:
    10.499
    Danke vergeben:
    1.500
    Die Kundengruppe "Admin" hat im Standard die Status -ID "0"
    Wenn das bei dir nicht geht, mach ein Ticket auf. Da ist irgend etwas kaputt.
     
  3. Manni_HB

    Manni_HB G-WARD 2012/13/14/15

    Registriert seit:
    26. April 2011
    Beiträge:
    9.098
    Danke erhalten:
    1.539
    Danke vergeben:
    908
    Ort:
    Bremen
    Das wäre dann die: $_SESSION['customer_id']
     
  4. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.744
    Danke erhalten:
    10.499
    Danke vergeben:
    1.500
    Die customers_id ist einzigartige Nummer des Kunden und für den Hauptadmin "1"
    Die customers_status_id ist aber die ID der Kundengruppe und die ist für Admin "0"

    Unbenannt.JPG