v4.2.x Defekte breadcrumb und zu viele 301 Weiterleitungen

Thema wurde von Kai Schoelzke, 3. September 2021 erstellt.

  1. Kai Schoelzke

    Kai Schoelzke Beta-Held

    Registriert seit:
    30. März 2016
    Beiträge:
    3.538
    Danke erhalten:
    468
    Danke vergeben:
    178
    #1 Kai Schoelzke, 3. September 2021
    Zuletzt bearbeitet: 3. September 2021
    Hallo, ob das jetzt nur diese Shop Version betrifft, habe ich nicht weiter Recherchiert, wobei ich das Problem im Testshop 1 nachstellen konnte.

    Bei meinen Arbeiten an Shops sind mir immer wieder solche URLs aufgefallen.

    Beispiel: https://www.gambio-shop.de/shop1/de/product_reviews.php?products_id=23&language=de die dann weitergeleitet werden auf https://www.gambio-shop.de/shop1/de/product_reviews.php?products_id=23 das ist für mich schon komisch. Frage mich warum.

    Wenn man sich jetzt die breadcrumb ansieht steht ganz rechts Bewertungen, wenn man im Testshop drauf klickt, bleibt die Seite Weiß, der Link ist https://www.gambio-shop.de/shop1/de/product_reviews.php es wird auf https://www.gambio-shop.de/shop1/de/reviews.php weitergeleitet. In meinem Fall gibt es eine Meldung

    Not Found
    The requested URL was not found on this server.

    Dann gibt es auf den Seiten Links zu den einzelnen Bewertungen mit Dynamischen Parametern https://www.gambio-shop.de/shop1/de....php?products_id=23&language=de&reviews_id=91 die nach dem Anklicken auf https://www.gambio-shop.de/shop1/de/product_reviews_info.php?products_id=23&reviews_id=91 weitergeleitet werden.

    Wenn man jetzt wieder den Link Bewertungen in der breadcrumb anklickt, https://www.gambio-shop.de/shop1/de/product_reviews.php?products_id=23&language=de landet man wieder auf https://www.gambio-shop.de/shop1/de/product_reviews.php?products_id=23

    Für meinen Geschmack etwas zu viele Weiterleitungen, das geht doch bestimmt um einiges besser, Bei Shops die viele Produktbewertungen haben, kommt da einiges an Weiterleitungen und vor allem an zu langen verketteten Weiterleitungen zusammen. Ich denke das ist SEO Technisch nicht gut.

    Nachtrag 1: In der breadcrumb vorn der Link zur Startseite geht nur auf die URL und nicht auf URL /de wird also ebenfalls wieder weitergeleitet.
    Nachtrag 2: In der Hersteller Info Box gibt es einen Link Mehr Artikel, der Produziert z.B. so was https://www.gambio-shop.de/shop1/?manu=m1_Herstellername.html wenn man das anklickt, wird man weitergeleitet auf https://www.gambio-shop.de/shop1/?gm_boosted_category=&language=de&manufacturers_id=1

    Bitte beachten Nachtrag 2 kann nicht im Testshop nachgestellt werden, da dort keine Hersteller hinterlegt sind bzw. es keinen mit der ID 1 gibt.

    Nachtrag 3: Auf den Seiten https://www.gambio-shop.de/shop1/de/product_reviews.php?products_id=164 werden auf der Linken Seitenleiste alle Aktiven Boxen angezeigt, auch wenn im Style Editor die Anzeige auf allen Seiten deaktiviert ist.

    Nachtrag 4: In der breadcrumb im kompletten Shop wird der Link zur Startseite immer nur als URL angegeben, es fehlt überall die Sprachkennung sofern aktiviert, damit wird eine 301 Weiterleitung für jede Seite produziert
     
  2. Kai Schoelzke

    Kai Schoelzke Beta-Held

    Registriert seit:
    30. März 2016
    Beiträge:
    3.538
    Danke erhalten:
    468
    Danke vergeben:
    178
    @Gambio kann sich das mal bitte jemand ansehen?
     
  3. Kai Schoelzke

    Kai Schoelzke Beta-Held

    Registriert seit:
    30. März 2016
    Beiträge:
    3.538
    Danke erhalten:
    468
    Danke vergeben:
    178
    Noch mal zum Verständnis, ich möchte hier keine Hilfe für einen einzelnen Shop. Ich wollte einfach nur meine Kenntnis über ein generelles Problem in allen Shops mitteilen und habe gehofft das sich einfach mal jemand meldet der sagt, schauen wir uns an! Mehr nicht!