DHL Versandlabel lässt sich nicht mehr erzeugen - nach Update auf 4.3.1.0

Thema wurde von joergmichels, 15. November 2020 erstellt.

  1. joergmichels

    joergmichels Mitglied

    Registriert seit:
    25. September 2015
    Beiträge:
    21
    Danke erhalten:
    3
    Danke vergeben:
    14
    Hallo,

    seitdem ich das Update von 4.2.0.0 auf 4.3.1.0 durchgeführt habe lässt sich das DHL Versandlabel nicht mehr erstellen. Es scheint aber aufgrund der Fehlermeldung bzw. die interne Adressierung um ein internes Problem zu handeln und nicht wie bei anderen Beiträgen hier im Forum an DHL. Hatte dieses Problem schon jemand ?

    Fehlermeldung:
    Das Versandlabel konnte nicht erzeugt werden. - SOAP-ERROR: Parsing Schema: can't import schema from 'file:/www/htdocs/......./GXMainComponents/Extensions/Geschaeftskundenversand/Soap/geschaeftskundenversand-api-3.1-schema-cis_base.xsd'

    Gruß aus Duisburg
     
  2. MTG_Gewürze

    MTG_Gewürze Mitglied

    Registriert seit:
    15. Juni 2019
    Beiträge:
    6
    Danke erhalten:
    2
    Danke vergeben:
    3
    Hallo,
    da bist Du nicht alleine.
    Habe gestern die 4.3 eingespielt und nun geht's auch bei mir nicht mehr.
    Evtl. jemand der weiterhelfen kann.
    Ticket hab ich schon aufgemacht.
    VG Mario
     
  3. nuernberg68er

    nuernberg68er Aktives Mitglied

    Registriert seit:
    8. Juli 2015
    Beiträge:
    29
    Danke erhalten:
    0
    Danke vergeben:
    34
    da bin ich heute wohl auch dabei ;-((((
     
  4. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    22. Juni 2011
    Beiträge:
    4.306
    Danke erhalten:
    1.533
    Danke vergeben:
    107
    Der Fehler ist etwas … sonderbar.

    An die Betroffenen: Bitte postet hier mal eben, bei welchem Hoster ihr seid und welche PHP-Version ihr verwendet.
     
  5. nuernberg68er

    nuernberg68er Aktives Mitglied

    Registriert seit:
    8. Juli 2015
    Beiträge:
    29
    Danke erhalten:
    0
    Danke vergeben:
    34
    PHP Version: 7.3.23
    Hoster: Domain Factory
     
  6. ludwiglanzinger

    ludwiglanzinger Neues Mitglied

    Registriert seit:
    28. November 2013
    Beiträge:
    2
    Danke erhalten:
    0
    Sind auch betroffen vom selben Fehler....

    Hoster: eigener Server bei Strato
    PHP: 7.3.24
     
  7. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    22. Juni 2011
    Beiträge:
    4.306
    Danke erhalten:
    1.533
    Danke vergeben:
    107
    Also bislang drei unterschiedliche Hoster (@MTG_Gewürze ist bei 1&1), aber alle mit PHP 7.3.23 bzw. 7.3.24.
    An der PHP-Version allein scheint es aber auch nicht zu liegen, denn auf meinem Testsystem mit PHP 7.3.24 ist das Problem nicht zu beobachten.

    Ich sollte vielleicht noch erwähnen, wo das Problem zu sein scheint:
    Das ist kein gültiger URI einer lokalen Datei, da fehlen zwei Schrägstriche, es müsste „file:///foo/bar/…“ heißen. Das ist aber nichts, was wir direkt beeinflussen, dieser URI wird von der PHP-SOAP-Erweiterung aus der WSDL-Datei zusammengezimmert, deren Pfad wir übergeben.

    Wer von den Betroffenen Zeit und Lust hat, kann gern mal ausprobieren, ob es mit PHP 7.4 oder 7.2 möglicherweise geht. Ergebnisse gern hier posten.
     
  8. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    22. Juni 2011
    Beiträge:
    4.306
    Danke erhalten:
    1.533
    Danke vergeben:
    107
    Vorläufiger Workaround:
    Bitte ersetzt die Datei GXMainComponents/Extensions/Geschaeftskundenversand/GeschaeftskundenversandConfigurationStorage.inc.php in euren Shops durch die beiliegende Version.
     

    Anhänge:

  9. MTG_Gewürze

    MTG_Gewürze Mitglied

    Registriert seit:
    15. Juni 2019
    Beiträge:
    6
    Danke erhalten:
    2
    Danke vergeben:
    3
    Hallo Marco,
    bei mir funktioniert es jetzt wieder.
    Ich gehe mal davon aus das Ihr die Datei schon reinkopiert habt.

    Danke und Grüße aus Grüna
    Mario
     
  10. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    22. Juni 2011
    Beiträge:
    4.306
    Danke erhalten:
    1.533
    Danke vergeben:
    107
    Ja, in der Tat. Sorry, hätte ich erwähnen sollen: Ich hatte deinen Shop zum Sondieren benutzt, weil wir von dir das erste Ticket zum Thema hatten.
     
  11. Konny_island

    Konny_island Mitglied

    Registriert seit:
    28. Dezember 2016
    Beiträge:
    14
    Danke erhalten:
    1
    Danke vergeben:
    14
    Hallo,
    jetzt mit der Datei funktioniert es auch bei mir wieder !

    Danke.
     
  12. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.458
    Danke erhalten:
    6.657
    Danke vergeben:
    2.014
    Wir haben übrigens wirklich die Vermutung, dass das Problem nicht bei allen Kunden auftritt, sondern bestimmte systemweite Kombinationen von PHP, der PHP SOAP Erweiterung und libxml zusammen auf Servern das Problem auslösen. Unsere funktionierenden Laborkisten haben zum Beispiel ein gutes Stück jüngere libxml Versionen als beobachtete, betroffene Shops. Kurios alles.

    Am Ende will sagen: Wenns einfach geht braucht man die Datei nicht zu ersetzen. Und Leute bei denen alles geht suchen ja nie, wenns aber bei Leuten einfach geht wäre darüber ne Meldung auch mal witzig.
     
  13. maria_justen

    maria_justen Neues Mitglied

    Registriert seit:
    13. November 2020
    Beiträge:
    1
    Danke erhalten:
    0
    Einfach war es in unserem Shop auch nicht, erst mit der geänderten Config-Datei läuft die Labelerstellung wieder. Wir hatten das Problem schon seit letztem Donnerstag und es auch dem Support gemeldet, von dort kam bis heute nur die Antwort, dass DHL hin- und wieder Probleme hat und es sicher daran liegen würde... Aber gut, dass das Forum nun Abhilfe schaffen konnte!
     
  14. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.458
    Danke erhalten:
    6.657
    Danke vergeben:
    2.014
    Das Forum ist auch das Team, das sind keine 2 strikt getrennten Sachen. Ich hatte am Wochenende tatsächlich auch schon nach einigen Meldungen die ich sah versucht das zu lösen, war aber gescheitert, das konnte erst ein Spezi für die Sache wie Marco heute morgen...
     
  15. MTG_Gewürze

    MTG_Gewürze Mitglied

    Registriert seit:
    15. Juni 2019
    Beiträge:
    6
    Danke erhalten:
    2
    Danke vergeben:
    3
    Hallo Wilken & Marco,
    kann es evtl. daran liegen das ich gleich von der 4.1 auf die 4.3 gegangen bin? Nur so als Überlegung.

    Also, noch mals mein Dank für die schnelle Hilfe.

    VG Mario
     
  16. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    2. Mai 2012
    Beiträge:
    331
    Danke erhalten:
    144
    Danke vergeben:
    78
    DHL hatte letzte Woche auch Probleme, eine tiefere Prüfung war somit gar nicht möglich, wenn die Gegenstelle nicht antwortet. Den Link zu allestoerungen.de mit der Störungsanzeige müsstest du von uns erhalten haben.
     
  17. joergmichels

    joergmichels Mitglied

    Registriert seit:
    25. September 2015
    Beiträge:
    21
    Danke erhalten:
    3
    Danke vergeben:
    14
    Hallo,

    ich bin bei All-Inkl.com und verwende PHP 7.2.

    Mit der neuen Datei funktioniert es jetzt auch wieder einwandfrei.

    Danke für die schnelle Hilfe.

    Gruss aus Duisburg.
     
  18. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    22. Juni 2011
    Beiträge:
    4.306
    Danke erhalten:
    1.533
    Danke vergeben:
    107
    Nein, die Größe des Updateschritts hat da keinen Einfluss. In GX4 v4.3.1.0 kam die Anbindung an v3.1 der DHL-GKV-Schnittstelle, und dabei haben wir auf Wunsch von DHL ein Detail bei der Art verändert, wie die Schnittstelle angesprochen wird. Das scheint aber bei einigen Hostern nicht so zu funktionieren, wie es soll; ich erkenne da noch kein klares Muster. Der Workaround in der von mir geposteten Datei besteht darin, wieder auf das alte Verfahren zurück zu gehen, das praktischerweise wieder funktioniert, obwohl DHL das ursprünglich blockiert hatte.
     
  19. ludwiglanzinger

    ludwiglanzinger Neues Mitglied

    Registriert seit:
    28. November 2013
    Beiträge:
    2
    Danke erhalten:
    0
    Funktioniert mit der zur Verfügung gestellten Datei wieder - Ticket schließe ich wieder !!
    Vielen Dank....
     
  20. Tierparkbedarf

    Tierparkbedarf Neues Mitglied

    Registriert seit:
    9. November 2020
    Beiträge:
    2
    Danke erhalten:
    0
    Bei uns das selbe Problem.
    Das Versandlabel konnte nicht erzeugt werden. - SOAP-ERROR: Parsing Schema: can't import schema from '......./GXMainComponents/Extensions/Geschaeftskundenversand/Soap/geschaeftskundenversand-api-3.1-schema-cis_base.xsd'