Fehlermeldung beim Modul "Kundengruppenrechte"

Thema wurde von lu, 19. März 2016 erstellt.

  1. lu

    lu Erfahrener Benutzer

    Registriert seit:
    15. Februar 2013
    Beiträge:
    167
    Danke erhalten:
    13
    Danke vergeben:
    38
    Hallo Forum,

    meine Shopversion ist 2.5.2.1. Ich habe jetzt erst bemerkt, dass ich im Adminbereich beim Klick auf "Kundengruppenrechte" folgende Fehlermeldung bekomme:

    WARNING(2): "require_once(/..../admin/gm/fckeditor/fckeditor.php): failed to open stream: No such file or directory"

    Fatal error: require_once(): Failed opening required '/.../admin/gm/fckeditor/fckeditor.php' (include_path='/../vendor/phpunit/dbunit:.../vendor/symfony/yaml:.:/usr/lib/php5.4') in .../admin/customer_groups.php on line 22
    COMPILE ERROR(64): "require_once(): Failed opening required '.../admin/gm/fckeditor/fckeditor.php' (include_path='.../vendor/phpunit/dbunit:.../vendor/symfony/yaml:.:/usr/lib/php5.4')"

    Das hat sicher damit zu tun, dass ich in der Vorgängerversion das Modul oder die Erweiterung für Kundengruppenrechte installiert habe, um schnell einzelnen Kundengruppe Rechte zuzuweisen. Mehrfach habe ich jetzt auch im Forum schon gelesen, dass dies in den neueren Shopversionen nicht mehr funktioniert.
    Leider weiß ich jetzt gar nicht, wie ich da weitermachen soll. Kann man da einfach eine neue Version drüber installieren z. B. diese hier: https://www.xycons.de/module-gx2/gx2-kundengruppenrechte.html

    Kann mir da jemand einen Tipp geben?
    Danke !
     
  2. Developer

    Developer Erfahrener Benutzer

    Registriert seit:
    7. November 2012
    Beiträge:
    2.651
    Danke erhalten:
    537
    Danke vergeben:
    92
    Hast Du damals das Modul installiert? Liegt Dir das Modul noch vor?
     
  3. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.744
    Danke erhalten:
    10.499
    Danke vergeben:
    1.500
    Du musst nur den FCK-Editor aus einer Datei löschen (admin/ customer_groups.php)
    Den gibt es in Deiner Version nicht mehr.

    HTML:
    require('includes/application_top.php');
      //require_once(DIR_FS_ADMIN . 'gm/fckeditor/fckeditor.php');
    
      define('FILENAME_CUSTOMER_GROUPS', 'customer_groups.php');
     
  4. lu

    lu Erfahrener Benutzer

    Registriert seit:
    15. Februar 2013
    Beiträge:
    167
    Danke erhalten:
    13
    Danke vergeben:
    38
    Danke, Barbara, die Löschung habe ich jetzt umgesetzt und diese Fehlermeldungen sind weg. Jetzt erhalte ich noch diese:
    Fatal error: Class 'MainFactory' not found in .../admin/customer_groups.php on line 26
    Leider weiß ich nun auch mit dieser nicht wirklich was anzufangen.

    Ja, Developer, das Modul müsste das gewesen sein: "SWGX2_0003 - Kundengruppenmodul"
     
  5. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.744
    Danke erhalten:
    10.499
    Danke vergeben:
    1.500
    Mehr habe ich an der Datei nicht geändert.
    Da müsstest du dann Holger einmal fragen.
     
  6. lu

    lu Erfahrener Benutzer

    Registriert seit:
    15. Februar 2013
    Beiträge:
    167
    Danke erhalten:
    13
    Danke vergeben:
    38
    Hallo,

    vielleicht kann mir ja doch jemand einen Tipp geben was es mit dieser Meldung, die ich beim Klick auf den Navigationspunkt "Kundengruppenrechte" im Adminbereich bekomme, auf sich hat:

    Fatal error
    : Class 'MainFactory' not found in .../admin/customer_groups.php on line 26

    Ich verstehe da leider nur Bahnhof.
    VG
    Lu
     
  7. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.744
    Danke erhalten:
    10.499
    Danke vergeben:
    1.500
    Das Modul "SWGX2_0003 - Kundengruppenmodul" ist von Holger (xycons.de)
    Das ist anders aufgebaut als das kleine Script hier aus dem Forum.
    Bitte wende Dich damit einmal an Holger, der kann Dir sagen was Du machen musst.
     
  8. HolgerNils (xycons.de)

    HolgerNils (xycons.de) G-WARD 2013/2014

    Registriert seit:
    29. Oktober 2011
    Beiträge:
    1.959
    Danke erhalten:
    449
    Danke vergeben:
    367
    @lu: Lade Dir die Nachfolgeversion herunter bei uns; im Shop hat sich mal etwas geändert, so dass die "alte" Version von seinerzeit nicht mehr funktionieren kann ab einer gewissen Version; 2.3 war das glaube ich. Ist ja kostenlos erhältlich.