Kann man eine Shop-DB einfach so von MySQL 5.5 auf eine höhere Version umstellen?

Thema wurde von Stromlinie21, 22. Oktober 2020 erstellt.

  1. Stromlinie21

    Stromlinie21 Erfahrener Benutzer

    Registriert seit:
    22. April 2015
    Beiträge:
    393
    Danke erhalten:
    39
    Danke vergeben:
    83
    Hallo zusammen,

    die Tage wurde bei mein Shop auf die Version 4.0 und PHP 7.4 umgestellt,

    Die Shop-DB läuft allerdings noch auf Version "MySQL 5.5".

    Als ich den Shop vor ca. einem Jahr von meinen Webspace-Provider mal auf eine höhere Version setzten ließ,
    war glaube ich 5.6 oder 5.7 gab es dann hinterher massive DB-Fehler.
    Das waren damals, glaube ich, generelle ASCII-Fehler oder so etwas in der Art.
    Auf jeden Fall musste auf 5.5 zurückgegangen werden.

    Frage:
    Sollte man eine Shop-DB von Version "MySQL 5.5"
    a) eigentlich problemlos auf die Version 5.6, 5.7, 6.0, 7.0, etc. setzen (lassen) können
    b) oder gibt es da ggf. (vorher) ETWAS ZU BEACHTEN?
     
  2. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.073
    Danke erhalten:
    6.464
    Danke vergeben:
    1.983
    Generell ist das möglich, auch das neueste MySQL 8.0 läuft mit aktuellen Shops. Es kommt nur etwas drauf an wie dabei vorgegangen wird, weil dabei selbstredend halt nichts verschwinden darf. Manchmal hilft es da auch sich vor dem Update einen Datenbankdump zu besorgen und den hinterher einfach rückzusichern.