nochmal mod_rewrite bei 1&1

Thema wurde von Anonymous, 2. Juli 2012 erstellt.

  1. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    6. Juni 2012
    Beiträge:
    413
    Danke erhalten:
    54
    Danke vergeben:
    55
    #1 Anonymous, 2. Juli 2012
    Zuletzt bearbeitet: 23. Juli 2012
    Hallo an die Programmier-Spezialisten!

    Ich hatte bereits versucht, mich mit meinem Thema an einen alten Thread anzuhängen, aber da wird´s wohl nicht gefunden ;-)
    (Link nur für registrierte Nutzer sichtbar.)

    Also nochmal:

    Webspace bei 1&1.

    Ich versuche, mod_rewrite zu aktivieren und bekomme derzeit die Fehlermeldung:
    Fehler: Umleitungsfehler. Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.

    (Vorher hatte ich ein paarmal Error 500, interner Fehler)

    Die fehlerhafte .htacess sieht derzeit aus wie angehängt.
    Ich würde mich sehr freuen, wenn mir jemand die Fehler nennen könnte, vielen Dank!
    (Die redirects sind die URL-Umleitungen von unserer vorherigen, gut gelisteten Seite)

    -------------------


    xxxx
     
  2. Kai Schoelzke

    Kai Schoelzke Beta-Held

    Registriert seit:
    30. März 2016
    Beiträge:
    3.591
    Danke erhalten:
    486
    Danke vergeben:
    193
    Hallo Wellisa,
    hast du noch ein paar Infos für uns?
    Shop Version?
    Hast du dein Hosting bei 1&1 aufgestockt, vielleicht ist ja jetzt php 5 inkl.?


    Was soll das?
    <Files ~ "^\.(htaccess|htpasswd)$">
    deny from all
    </Files>
    Willst du den Shop verstecken?
     
  3. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    6. Juni 2012
    Beiträge:
    413
    Danke erhalten:
    54
    Danke vergeben:
    55
    Hallo Kai,

    Shop Version GX2 v2.0.9d r6045

    1&1 Hosting Homepage Basic mit Hompage Baukasten plus, mit php 5


    Wie das in die Datei gekommen ist, weiss ich leider auch nicht (wahrscheinlich, weil wir zwischenzeitlich mal über temporäre Passwortvergabe nachgedacht haben). Es ist kein Passwort vergeben, und es soll auch zukünftig keines vergeben werden.
    Und versteckt werden soll natürlich auch nichts ;-)
    Ich kann es rauslöschen. Allerdings vermute ich, dass das nicht der Hauptfehler ist. Denn in der momentan laufenden .htaccess (ohne die mod_rewrite Erweiterung von Gambio) ist dieser Abschnitt auch aufgeführt. Und die Seite ist problemlos online.

    Wäre sehr nett, wenn Du mir weiterhelfen könntest - danke sehr!
     
  4. Kai Schoelzke

    Kai Schoelzke Beta-Held

    Registriert seit:
    30. März 2016
    Beiträge:
    3.591
    Danke erhalten:
    486
    Danke vergeben:
    193
    Hallo Wellisa,
    lösche mal das

    <Files ~ "^\.(htaccess|htpasswd)$">
    deny from all
    </Files>

    und

    AddType x-mapp-php5 .php .php5 .htm .html

    Wenn du jetzt schon php5 auf deinem Hosting hast muss das zweite unbedingt raus
     
  5. Kai Schoelzke

    Kai Schoelzke Beta-Held

    Registriert seit:
    30. März 2016
    Beiträge:
    3.591
    Danke erhalten:
    486
    Danke vergeben:
    193
    Ach und noch was,
    du hast mal bei einem Service Pack die .htaccess nicht mit angepasst.

    Das muss da auch noch raus

    RewriteBase /Shop/
    RewriteRule . - [E=no-gzip:1]

    und das
    RewriteCond %{REQUEST_FILENAME} =.*\.(php|css|js|gif|jpg|jpeg|png)$
    muss geändert werden in
    RewriteCond %{REQUEST_FILENAME} ^(.*)\.(php|css|js|gif|jpg|jpeg|png)$ [NC]
     
  6. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    6. Juni 2012
    Beiträge:
    413
    Danke erhalten:
    54
    Danke vergeben:
    55
    #6 Anonymous, 3. Juli 2012
    Zuletzt bearbeitet: 23. Juli 2012
    Hallo Kai,

    vielen Dank für Deine Hilfe.

    Ich habe Deine Änderungen durchgeführt.
    Leider hat sich das Ergebnis nicht geändert.
    Die Fehlermeldung im Wortlaut:
    ------------------------------------
    Fehler: Umleitungsfehler

    Die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.

    Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder abgelehnt
    werden.
    ---------------------------------

    Ich hatte zwischenzeitlich auch mal

    order deny,allow

    und danach auch

    Options -MultiViews

    rausgenommen.
    Leider immer mit demselben Ergebnis und derselben Fehlermeldung.

    Hier zur Kontrolle die geänderte Datei:

    ----------------------
     
  7. Kai Schoelzke

    Kai Schoelzke Beta-Held

    Registriert seit:
    30. März 2016
    Beiträge:
    3.591
    Danke erhalten:
    486
    Danke vergeben:
    193
    Dann nim mal das raus!

    RewriteCond %{HTTP_HOST} ^www\.silknature\.de$
    RewriteRule ^(.*)$ http://www.silknature.de/$1 [R=permanent,L]

    Das ist die umleitung zur Domain mit www.
    teste mal, ich glaube bei 1und1 muss das anders aussehen
     
  8. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    6. Juni 2012
    Beiträge:
    413
    Danke erhalten:
    54
    Danke vergeben:
    55
    #8 Anonymous, 3. Juli 2012
    Zuletzt bearbeitet: 3. Juli 2012
    OK !
    Das sieht schon mal ganz gut aus - beim Hochladen gibt es keine Fehlermeldung mehr.

    Mal sehen, was passiert, wenn ich nacher im Admi-Bereich den Gambio SEO Boost anschalte. (Schaffe ich erst in ein paar Stunden; muss ja, falls es klappen sollte, danach auch noch die redirects anpassen).
    Ich melde mich wieder,
    bis dahin vielen Dank!
     
  9. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    6. Juni 2012
    Beiträge:
    413
    Danke erhalten:
    54
    Danke vergeben:
    55
    #9 Anonymous, 3. Juli 2012
    Zuletzt bearbeitet: 23. Juli 2012
    GRRRRRRR!

    Nach dem Einschalten des Gambio SEO Boost im Adminbereich spuckt der 1&1-Server wieder Fehlermeldung aus.

    Ich habe mal "Suchmaschinenfreundliche URLs Pro für Kategorieseiten aktivieren" eingeschaltet.

    xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

    Soweit so gut.
    Aber: Die entsprechende Seite wird nicht angezeigt, sondern die Fehlermeldung:
    -----------------
    500 Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webadmin@kundenserver.de and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    --------------------------------

    Und nun?


    Grüsse,
    Wellisa
     
  10. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    6. Juni 2012
    Beiträge:
    413
    Danke erhalten:
    54
    Danke vergeben:
    55
    und noch etwas ist mir aufgefallen:
    Nach dem Hochladen der htaccess-Datei incl. Gambio SEO Boost (s. #6) springt die eigene 404-Fehlerseite nicht mehr an.
    Bei 404-Fehlern wird ebenfalls "500 Internal Server Error" ausgegeben.
     
  11. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    6. Juni 2012
    Beiträge:
    413
    Danke erhalten:
    54
    Danke vergeben:
    55
    #11 Anonymous, 4. Juli 2012
    Zuletzt bearbeitet: 23. Juli 2012
    Hallo nochmal,

    habe überlegt, mode_rewrite in der .htacess - ohne die Gambio-SEO-Boost-Erweiterung - einzeln per Hand einzugeben.
    Es geht schließlich nur um die Umbenennung von rund 5-10 Seiten (v.a. 5 Kategorien, sowie ein paar Seiten mit Content).
    1&1 hat allerdings offenbar seine eigenen Syntax-Spezialitäten.

    Ich habe bei 1&1 nachgefragt, aber als Antwort leider nur den Hinweis auf 2 Beispiel-Umleitungen bekommen, mit denen ich leider nur bedingt etwas anfangen kann:

    -------------------------
    Aus (Link nur für registrierte Nutzer sichtbar.) mache (Link nur für registrierte Nutzer sichtbar.)

    .htaccess

    Options -MultiViews
    RewriteEngine on
    RewriteCond %{REQUEST_URI} news/(.*)\.html$
    RewriteRule news/(.*)\.html$ /news.php?id=$1

    Aus (Link nur für registrierte Nutzer sichtbar.) mache (Link nur für registrierte Nutzer sichtbar.)

    .htaccess

    Options -MultiViews
    RewriteEngine on
    RewriteCond %{REQUEST_URI} user/(.*)$
    RewriteRule user/(.*)$ /user.php?id=$1

    ---------------------------

    Bei mir wäre z.B. Folgendes von Nöten:

    xxxxxxxxxxxxxxxxxxxxxxxxxxxxx



    Hat hier vielleicht noch jemand einen Tipp?

    Oder macht es Sinn, hierzu ein Gambio-Ticket zu eröffnen? (Falls ja, wohl besser erst, wenn die Button-Lösung erledigt ist...)

    Danke für Eure Geduld!
     
  12. Nicki

    Nicki Erfahrener Benutzer

    Registriert seit:
    12. März 2012
    Beiträge:
    469
    Danke erhalten:
    57
    Danke vergeben:
    29
    Hab das gleiche Problem mit einem Shop der bei 1&1 liegt.
     
  13. Partysan

    Partysan Erfahrener Benutzer

    Registriert seit:
    2. Juni 2012
    Beiträge:
    192
    Danke erhalten:
    21
    Danke vergeben:
    52
    Sieht so aus als on in Deinem Hostingpaket mod_rewrite nicht unterstützt wird.
    [...]
    ACHTUNG:

    Ihr Server muss mod_rewrite unterstützen! Andernfalls kann der Shop nicht mehr aufgerufen werden, nachdem die ".htaccess"-Datei ins Hauptverzeichnis kopiert wurde.
    Sollte der Shop unerwartet nicht mehr aufrufbar sein, löschen Sie die ".htaccess"-Datei aus dem Hauptverzeichnis des Shops. Falls Ihr FTP-Programm keine ".htaccess"-Dateien anzeigen sollte, können Sie zum Deaktivieren auch die ".htaccess" aus dem gm/seo_boost_aus/ Ordner (Gambio-CD) ins Hauptverzeichnis kopieren, um die vorhandene zu ersetzen.
    [...]
    nimm mal die .htaccess komplet raus. Dann sollte Dein Shop wieder funktionieren. Ansonsten Hostingpaket bei http://do.de buchen. Die haben alles was man braucht.
     
  14. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    6. Juni 2012
    Beiträge:
    413
    Danke erhalten:
    54
    Danke vergeben:
    55
    Laut 1und1 wird mod_rewrite standardmässig unterstützt.
    Allerdings gibt es wohl Besonderheiten bei der Syntax.
    Wenn man mal nach der Sache googelt, gibt es wohl eine ganze Reihe von 1und1-Kunden, die vor diesem Problem stehen. (Einige scheinen es auch gelöst zu haben - ich leider noch nicht...)
     
  15. Kai Schoelzke

    Kai Schoelzke Beta-Held

    Registriert seit:
    30. März 2016
    Beiträge:
    3.591
    Danke erhalten:
    486
    Danke vergeben:
    193
    Hallo, bei 1und 1 ist noch nicht überall php5 aktiviert.
    versucht mal das in Euerer .htaccess

    AddType x-mapp-php5 .php .php5 .htm .html
     
  16. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    6. Juni 2012
    Beiträge:
    413
    Danke erhalten:
    54
    Danke vergeben:
    55
    bei mir läuft php5

    daran dürfte es leider nicht liegen.
     
  17. Kai Schoelzke

    Kai Schoelzke Beta-Held

    Registriert seit:
    30. März 2016
    Beiträge:
    3.591
    Danke erhalten:
    486
    Danke vergeben:
    193
    Ich habe mit dem Inhalt problemlos einen Shop bei 1und1 am laufen

    ## Gambio SEO Boost
    ## www.gambio.de
    AddType x-mapp-php5 .php .php5 .htm .html
    RewriteEngine on
    RewriteCond %{REQUEST_FILENAME} ^(.*)\.(php|css|js|gif|jpg|jpeg|png)$ [NC]
    RewriteRule ^(.+) - [L]
    RewriteCond %{REQUEST_URI} (.*)?/admin/(.*)
    RewriteRule ^(.+) - [L]
    RewriteCond %{REQUEST_URI} (.*)?/images/(.*)
    RewriteRule ^(.+) - [L]
    RewriteCond %{REQUEST_URI} (.*)?/templates/(.*)
    RewriteRule ^(.+) - [L]

    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^(.+) - [L]
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule ^(.+) - [L]
    RewriteCond %{REQUEST_FILENAME} -l
    RewriteRule ^(.+) - [L]

    ##boosted CONTENT
    RewriteBase /
    RewriteRule (.*/)?info/([A-Za-z0-9_-]+)\.html.* shop_content.php?gm_boosted_content=$2&%{QUERY_STRING} [PT,L]
    ##boosted PRODUCTS
    RewriteBase /
    RewriteRule (.*/)?([A-Za-z0-9_-]+)\.html product_info.php?gm_boosted_product=$2&%{QUERY_STRING} [PT,L]
    ##boosted CATEGORIES
    RewriteBase /
    RewriteRule (.*/)?([A-Za-z0-9_-]+)/?.* index.php?gm_boosted_category=$2&%{QUERY_STRING} [L]
     
  18. Avenger

    Avenger G-WARD 2012/13/14/15

    Registriert seit:
    26. April 2011
    Beiträge:
    4.771
    Danke erhalten:
    1.478
    Danke vergeben:
    89
    Die Lösung für Eure Probleme: sucht Euch einen vernünftigen Provider!

    Man sollte es eigentlich ablehnen, noch Probleme mit Hostings bei 1 & 1 und Strato zu beantworten....
     
  19. Nicki

    Nicki Erfahrener Benutzer

    Registriert seit:
    12. März 2012
    Beiträge:
    469
    Danke erhalten:
    57
    Danke vergeben:
    29
    Ja wenn es den mein Shop währe...

    Mich hats gleich doppelt getroffen, einen bei 1&1 und einen bei Strato

    aaaaahhhrrrggggg
     
  20. Teelirium

    Teelirium Erfahrener Benutzer

    Registriert seit:
    13. Juni 2012
    Beiträge:
    287
    Danke erhalten:
    22
    Danke vergeben:
    141
    Ja, jeder schimpft über 1&1, aber leider ist es bei mir auch das Problem. Auch mit der oben angegebenen .htaccess läuft bei mir nix. Interessant ist aber bei mir, dass mit der normalen SEO BOOST .htaccess Datei die Startseite des Shops problemlos aufrufbar ist, lediglich Unterseiten gehen nicht. Auch wenn 1&1 sche*** ist, eine Lösung wäre trotzdem klasse. Bei mir läuft definitv PHP5.... kann leider nicht von heute auf morgen zu einem anderen Provider wechseln :-(