PHP Version für Shop 3.6.0.2

Thema wurde von Anonymous, 10. Januar 2020 erstellt.

  1. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    7. April 2014
    Beiträge:
    174
    Danke erhalten:
    8
    Danke vergeben:
    48
    Habe eine Nachricht von Strato erhalten, daß die PHP-Version 7.1 im Februar 2020 eingestellt wird. Danach könnte ich diese Version noch dazubuchen für einen Betrag X.

    Nachdem mein Shop noch auf 3.6.0.2 läuft, habe ich nun die Frage ob ich die PHP-Version 7.2 nutzen kann?

    Der Shop läuft nur noch bis Ende 2020. Danach wird ein der Shop komplett umgebaut. Laut dem Link (Link nur für registrierte Nutzer sichtbar.)
    kann ich nur 7.1 verwenden. Gib es Erfahrungen mit 7.2?


    Vielen Dank
    Rolf
     
  2. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    15.732
    Danke erhalten:
    5.849
    Danke vergeben:
    1.783
    Ich würde da schon Probleme erwarten.
     
  3. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    7. April 2014
    Beiträge:
    174
    Danke erhalten:
    8
    Danke vergeben:
    48
    Kannst Du mir evtl. die Probleme nennen? Oder auf was muß ich achten.
     
  4. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    15.732
    Danke erhalten:
    5.849
    Danke vergeben:
    1.783
    Nein, kann ich nicht. Ich kann mich erinnern, dass wir nach 3.6.0.2 noch öfter einen Haufen Codeänderungen für neueres PHP gemacht haben, und zwar zuviele um zu sagen wird schon gehen. Das aber aus den Archiven zu suchen und zu extrahieren, das wär ein Job für einen Doofen und einen Tag, an dem man sonst nichts mehr tun muss, also richtig viel Arbeit.
     
  5. CITYJEWELS

    CITYJEWELS Erfahrener Benutzer

    Registriert seit:
    13. März 2015
    Beiträge:
    440
    Danke erhalten:
    82
    Danke vergeben:
    170
    Das funktioniert nicht, das ist nicht kompatibel.

    Also entweder PHP 7.2 buchen oder Shop updaten.