v3.5.x Preise auf Rechnung und im Warenkorb kritischer Formatfehler

Thema wurde von mymarmor, 7. August 2017 erstellt.

  1. mymarmor

    mymarmor Erfahrener Benutzer

    Registriert seit:
    11. Juni 2017
    Beiträge:
    114
    Danke erhalten:
    10
    Danke vergeben:
    14
    Hallo,

    seit meinem Update auf Version 3.5.3.1 werden die Beträge mit merkwürdigen Bezeichnungen gedruckt.
    Kennt jemand dieses Problem. Ebenso erscheinen merkwürdige Zeichen vor und nach den Beträgen im Warenkorb usw.

    Kann jemand schnell helfen ?

    Ticket habe ich eröffnet, aber das dauert ja immer Tage.

    Gruß
    Andreas Spedition.JPG Versandkosten.JPG
     
  2. Dennis (MotivMonster.de)

    Dennis (MotivMonster.de) G-WARD 2013/14/15/16

    Registriert seit:
    22. September 2011
    Beiträge:
    30.416
    Danke erhalten:
    5.917
    Danke vergeben:
    1.060
    Beruf:
    Mann für alles :)
    Ort:
    Weilburg
    idR innerhlab eines Tages.

    Deine "komischen" Zeichen sind kodierungszeichen für Umlaute - Hast du evtl. Texte angepasst oder an den Dateien gespielt?
     
  3. mymarmor

    mymarmor Erfahrener Benutzer

    Registriert seit:
    11. Juni 2017
    Beiträge:
    114
    Danke erhalten:
    10
    Danke vergeben:
    14
    Ich habe an keinen Dateien gespielt, habe nur die Rechnungstexte angepasst heute.
    Gambio hat etwas wegen dem Leerzwichenfehler in der Date Shop/includes/classes/xtcPrice.php verändert.
    Kann es daran liegen ?
     
  4. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.555
    Danke erhalten:
    10.407
    Danke vergeben:
    1.497
    Da solltest Du Dich noch einmal an Gambio wenden.
      (mit ; am Ende) ist der Code für ein Leerzeichen.
    Das letzte Zeichen scheint bei Dir zu fehlen, deshalb wird das vermutlich nicht als Leerzeichen erkannt.
     
  5. mymarmor

    mymarmor Erfahrener Benutzer

    Registriert seit:
    11. Juni 2017
    Beiträge:
    114
    Danke erhalten:
    10
    Danke vergeben:
    14
    Hallo,
    Gambio hatte die Dateien verändert für mich, da bei mir bei einigen Artikeln bei Preis ab ein Leerzeichen fehlte, nur beim MAC. Jetzt funktionieren die Rechnungen wieder, aber das Leerzeichen fehlt weiterhin :-(
     
  6. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.555
    Danke erhalten:
    10.407
    Danke vergeben:
    1.497
    Deshalb meinte ich ja auch, dass Du dich noch einmal an Gambio wenden solltest.
    Da passt irgend etwas mit dem Code nicht, oder nicht überall. Das sollte Gambio noch einmal überprüfen.
     
  7. mymarmor

    mymarmor Erfahrener Benutzer

    Registriert seit:
    11. Juni 2017
    Beiträge:
    114
    Danke erhalten:
    10
    Danke vergeben:
    14
    Hallo Barbara,
    ich werde das Ticket mit dem fehlenden Leerzeichnen nun leider ein drittes mal eröffnen.
    Hoffe, das Fehler behoben wird.
    Gruß
    Andreas