v4.4.x Session Gültigkeitsdauer

Thema wurde von Anonymous, 14. Januar 2022 erstellt.

  1. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    18. Juli 2019
    Beiträge:
    385
    Danke erhalten:
    61
    Danke vergeben:
    22
    Kennt jemand den maximal möglichen Wert für die Session Gültigkeitsdauer?
    Bei mir bleibt das fix auf 90 stehen, egal was ich eingebe, ich werde aber weitaus schneller wieder heraus geworfen, was sehr sehr nervt.

    Kennt jemand einen weg das zu verlängern?

    4.4.0.1 habe ich.
     
  2. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    34.569
    Danke erhalten:
    10.829
    Danke vergeben:
    1.539
    Weiß nicht ob es in einer 4.4 auch noch so ist, aber in GX3 hat es geholfen die Admin-Startseite in einem 2. Fenster offen zu haben.
     
  3. Ralf von SC

    Ralf von SC Erfahrener Benutzer

    Registriert seit:
    3. Juni 2019
    Beiträge:
    366
    Danke erhalten:
    47
    Danke vergeben:
    20
    Das hatte ich auch ständig, das problem ist behoben bei Version 4,5.1.1
    Weiß aber nicht warum!
     
  4. Christian Mueller

    Christian Mueller Beta-Held

    Registriert seit:
    4. Juli 2011
    Beiträge:
    3.479
    Danke erhalten:
    770
    Danke vergeben:
    259
    4.4.0.1 hat sowieso diverse Bugs. Du solltest zumindest auf 4.4.0.3 updaten. Das bringt keine funktionellen Änderungen mit sich, aber Fehlerbereinigungen.
     
  5. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.516
    Danke erhalten:
    2.506
    Danke vergeben:
    815
    Es war zuvor tatsächlich fehlerhaft und wurde in in GX 4.5 korrigiert.
     
  6. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    18. Juli 2019
    Beiträge:
    385
    Danke erhalten:
    61
    Danke vergeben:
    22
    Bei den Updates bin ich generell sehr vorsichtig geworden, da gab es doch zuviel Scherereien bisher.
    Ich muss mal in mich gehen ob sich das Risiko lohnt dafür.
     
  7. Christian Mueller

    Christian Mueller Beta-Held

    Registriert seit:
    4. Juli 2011
    Beiträge:
    3.479
    Danke erhalten:
    770
    Danke vergeben:
    259
    Ein Update auf 4.5 kommt für mich aus vielerlei Gründen nicht in Frage. Gibt es die Möglichkeit den Fehler in 4.4 zu korrigieren?
     
  8. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.516
    Danke erhalten:
    2.506
    Danke vergeben:
    815
    Du kannst den Fehler umgehen, indem du eine der älteren Gambio Admin Seiten offen lässt, wie zum Beispiel die Bestellübersicht.
     
  9. Christian Mueller

    Christian Mueller Beta-Held

    Registriert seit:
    4. Juli 2011
    Beiträge:
    3.479
    Danke erhalten:
    770
    Danke vergeben:
    259
    OK, ich dachte schon, das wäre ein Problem von Kunden- und nicht von Admin-Sessions.
     
  10. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.516
    Danke erhalten:
    2.506
    Danke vergeben:
    815
    Die Option gilt ausschließlich für Admins und greift auch nur im Gambio Admin. Wenn die Sessionlaufzeit generell erhöht werden soll, muss das der Hoster tun.
     
  11. Christian Mueller

    Christian Mueller Beta-Held

    Registriert seit:
    4. Juli 2011
    Beiträge:
    3.479
    Danke erhalten:
    770
    Danke vergeben:
    259
    Wäre dann gut, wenn der Titel des Threads angepasst würde.
     
  12. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.516
    Danke erhalten:
    2.506
    Danke vergeben:
    815
    Ich finde den Titel jetzt nicht so verkehrt und lasse dem Threadersteller jetzt seine Formulierung.
     
  13. Ralf von SC

    Ralf von SC Erfahrener Benutzer

    Registriert seit:
    3. Juni 2019
    Beiträge:
    366
    Danke erhalten:
    47
    Danke vergeben:
    20
    Danke Moritz,
    und Ihr hattet mir in meinem Ticket geschrieben ich soll den Hosting Anbieter Anschreiben es liegt an der
    "session.gc_maxlifetime"
    und der Ärmste hat alles mögliche gemacht. ;)
     
  14. Christian Mueller

    Christian Mueller Beta-Held

    Registriert seit:
    4. Juli 2011
    Beiträge:
    3.479
    Danke erhalten:
    770
    Danke vergeben:
    259
    ja... genau.. und deshalb sollte man session.gc_maxlifetime und Admin-Sessions möglichst auseinanderhalten.

    Deshalb:
     
  15. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.516
    Danke erhalten:
    2.506
    Danke vergeben:
    815
    Das ist tatsächlich eine Lösung, um das Problem für alle Seiten, also auch im Gambio Admin, zu lösen. "session.gc_maxlifetime" bestimmmt, wie lange die Session am Leben bleibt, solange sie nicht genutzt wird.
     
  16. Christian Mueller

    Christian Mueller Beta-Held

    Registriert seit:
    4. Juli 2011
    Beiträge:
    3.479
    Danke erhalten:
    770
    Danke vergeben:
    259
    Um das noch etwas klarer auszudrücken für alle Nicht-Nerds die mitlesen: Das ist eine Einstellung für die php.ini in den PHP-Einstellungen des Servers, keine Einstellung irgendwo in Gambio. Wer da nicht selbst drankommt, muss das von seinem Provider ändern lassen, falls der das zulässt.
     
  17. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    13. Juni 2011
    Beiträge:
    694
    Danke erhalten:
    138
    Danke vergeben:
    138
    Also bei mir ist die session.gc_maxlifetime serverseitig auf 86400 eingestellt.
    Ruf ich die Server Info im Shop auf, steht sie auf 1440.
    Ändere ich in der Datei GambioCore/Session/SessionService.php den Wert 1440 auf zB 7200 wird das auch in der Server Info übernommen und ich werde auf der Admin-Startseite nicht mehr so schnell rausgeschmissen. (GX4.4.0.3)
     
  18. Christian Mueller

    Christian Mueller Beta-Held

    Registriert seit:
    4. Juli 2011
    Beiträge:
    3.479
    Danke erhalten:
    770
    Danke vergeben:
    259
    Kann ich so nicht bestätigen. Wenn ich in der php.ini session.gc_maxlifetime ändere, dann ändert sich das auch in der phpinfo().
     
  19. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    13. Juni 2011
    Beiträge:
    694
    Danke erhalten:
    138
    Danke vergeben:
    138
    So schaut es bei mir aus, wenn ich direkt die Info.php vom Server aufrufe
    Screenshot 2022-01-20 182859.jpg

    und so, wenn ich die Serverinfo im Shop aufrufe
    Screenshot 2022-01-20 183006.jpg

    Sehr eigenartig ;)
     
  20. walterlenk

    walterlenk Erfahrener Benutzer

    Registriert seit:
    28. September 2011
    Beiträge:
    300
    Danke erhalten:
    74
    Danke vergeben:
    34
    Wo liegt denn die "Info.php" die Du direkt am Server aufrufst?

    Ich denke dort wird Dir evtl. die Manipulation der session.gc_maxlifetime durch den Shop (die 7200 die Du in der /GambioCore/Session/SessionService.php eingestellt hast) noch nicht "rein funken" (nicht wirksam sein).

    Grüße
    Walter