v4.0.x Sonderzeichen werden über die Suche nicht gefunden

Thema wurde von chris801255, 5. Juli 2020 erstellt.

  1. chris801255

    chris801255 Erfahrener Benutzer

    Registriert seit:
    26. Mai 2011
    Beiträge:
    264
    Danke erhalten:
    14
    Danke vergeben:
    110
    Wir haben einige Artikel, die im Artikelnamen ein Sonderzeiden wie z. B. "&" haben. Wenn man jetzt diesen Artikelnamen über die Suche sucht, wird kein Produkt gefunden. Sucht man den Namen und nimmt nur das "&" weg, wird der Artikel gefunden. Ich habe das gerade im Gambio Testshop probiert (https://www.gambio-shop.de/shop1/de/beauty-schmuck/herren/kleidung-34/t-shirt-mit-schal-kragen.html). Nennt man das Shirt um in "T-Shirt mit Schal-Kragen & halbarm", wird es über die Suche gefunden, wenn man "T-Shirt mit Schal-Kragen halbarm" eingibt. Wenn man aber den kompletten Namen "T-Shirt mit Schal-Kragen & halbarm" eingibt, wird nichts gefunden.
     
  2. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    22. Juni 2011
    Beiträge:
    4.415
    Danke erhalten:
    1.579
    Danke vergeben:
    116
    Unabhängig von der technischen Dimension: Das &-Zeichen hat an dieser Stelle nichts zu suchen. Siehe z. B. (Link nur für registrierte Nutzer sichtbar.) und (Link nur für registrierte Nutzer sichtbar.) und natürlich (Link nur für registrierte Nutzer sichtbar.).
     
  3. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.391
    Danke erhalten:
    2.429
    Danke vergeben:
    783