StyleEdit Farbangaben primary / default werden ignoriert

Thema wurde von Anonymous, 3. April 2021 erstellt.

  1. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    1. Februar 2014
    Beiträge:
    124
    Danke erhalten:
    7
    Danke vergeben:
    69
    #1 Anonymous, 3. April 2021
    Zuletzt bearbeitet: 9. April 2021
    Hallo Zusammen,

    ich arbeite aktuell an der Umstellung vom Honeygrid Template aufs Honeygrid Theme. Ich habe festgestellt, dass die Angaben der primary / default Farben, an mehreren Stellen ignoriert werden:

    Zum Beispiel wird der Primary Button "zum Warenkorb" im Standard Blau wiedergegeben, nicht in meiner im StyleEdit festgelegten primary Farbe.
    Diese wird für den Button erst übernommen wenn ich sie nicht mittels $btn-primary-color übergebe, sondern hart mittels Farbwert.

    Gleiches trifft auch für die Hover Farbe der Hauptkategorien im Megadropdown zu. Wieder taucht das Standard Blau auf, nicht meine vorgegebene Farbe. Die Subkategorien (2. Ebene) werden hingegen farblich korrekt wiedergegeben.

    Hat vielleicht Jemand eine Idee wo der Fehler liegen könnte?

    Danke für Eure Zeit.
     
  2. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    1. Februar 2014
    Beiträge:
    124
    Danke erhalten:
    7
    Danke vergeben:
    69
    FYI:
    Die Rückmeldung des Supports dazu lautet:

    "Das "Überlagern" der Hauptkategorien mit einer anderen Farbe ist ein Fehler im SE4. Hier hilft es nur das gezielt per CSS einmal zu überschreiben."
     
  3. Anonymous

    Anonymous Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    947
    Danke erhalten:
    747
    Danke vergeben:
    182
    @Rike Im StyleEdit gibt es für den Warenkorb Button noch eine extra Option um die Farbe darfür festzulegen, schau mal unter "Bereiche->Allgemein->Buttons" und dann "In den Warenkorb" hier ist standardmäßig eine fester Farbe vorgesehen wenn du da "$btn-primary-bg" einträgst wir die Farbe auch übernommen. Die gleiche Farbe kannst du dann auch für "Rahmenfarbe in den Warenkorb-Button" eintragen. Wenn du das so konfigurierst, dann wird die Farbe auch immer in Abhängigkeit der Primärfarbe für Buttons übernommen.
     
  4. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    1. Februar 2014
    Beiträge:
    124
    Danke erhalten:
    7
    Danke vergeben:
    69
    Danke @Till (Gambio) das Problem mit dem Button konnte ich inzwischen bereits lösen.

    Allerdings nicht das mit der Hover Farbe der Hauptkategorien im Megadropdown. Ich konnte noch nicht den dazugehörigen Style ausfindig machen um diesen im eigenen CSS zu überschreiben.
     
  5. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    1. Februar 2014
    Beiträge:
    124
    Danke erhalten:
    7
    Danke vergeben:
    69
    #5 Anonymous, 9. April 2021
    Zuletzt bearbeitet: 9. April 2021
    Ich denke, ich habe inzwischen die zum Megadropdown zugehörige Style-Angabe gefunden:

    Code:
    @media (min-width: 768px)
    .navbar-collapse .navbar-categories ul.navbar-nav > li > ul.dropdown-menu > li.active > a, .navbar-collapse .navbar-categories ul.navbar-nav > li > ul.dropdown-menu > li a:hover, .navbar-collapse .navbar-categories ul.navbar-nav > li > ul.dropdown-menu > li a:active {
        background: transparent;
        color: #337ab7;
    }
    Allerdings hat eine Farbänderung daran dann doch keine entsprechende Änderung zur Folge. :( Der Hover Effekt der Navigation ist und bleibt in der ersten Ebene blau.

    Gleiches gilt für das Cookie Panel. Die Akzentfarbe bleibt Blau, meine Angaben werden nicht übernommen.
     
  6. Anonymous

    Anonymous Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    947
    Danke erhalten:
    747
    Danke vergeben:
    182
    @Rike Wenn das wirklich unabhängig vom Gerät sein soll, dann entferne bitte das
    @media (min-width: 768px)

    Außerdem ist der Code fehlerhaft es müsste wenn dann wie folgt aussehen:

    Code:
    @media (min-width: 768px)
    {
    .navbar-collapse .navbar-categories ul.navbar-nav > li > ul.dropdown-menu > li.active > a, .navbar-collapse .navbar-categories ul.navbar-nav > li > ul.dropdown-menu > li a:hover, .navbar-collapse .navbar-categories ul.navbar-nav > li > ul.dropdown-menu > li a:hover {
        background: transparent;
        color: #337ab7;
    }
    }
     
  7. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    1. Februar 2014
    Beiträge:
    124
    Danke erhalten:
    7
    Danke vergeben:
    69
    #7 Anonymous, 10. April 2021
    Zuletzt bearbeitet: 10. April 2021
    Danke, das hat nun endlich zur gewünschten Änderung in der Navigation geführt!
    Anmerkung: Den fehlerhaften Code habe ich - sofern ich es richtig erinnere - aus dem Theme-Code herauskopiert.
     
  8. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.278
    Danke erhalten:
    10.316
    Danke vergeben:
    1.486
    Hast Du das über die Browser-Console gemacht?
    Die unterschlägt bei @media immer die zusätzlichen Klammern. In die Falle bin ich auch schon getreten.
     
  9. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    1. Februar 2014
    Beiträge:
    124
    Danke erhalten:
    7
    Danke vergeben:
    69
    Ja, genau. Danke Dir für den Hinweis!