v2.7.x SyntaxError: expected expression, got '<'

Thema wurde von easy-entertain, 3. Juni 2016 erstellt.

  1. easy-entertain

    easy-entertain Aktives Mitglied

    Registriert seit:
    21. Januar 2015
    Beiträge:
    26
    Danke erhalten:
    0
    Danke vergeben:
    4
    #1 easy-entertain, 3. Juni 2016
    Zuletzt bearbeitet: 3. Juni 2016
    Hallo,

    nach einem Shopupdate von einer 2.0.1 auf 2.74.2 habe ich jetzt einen jquery Fehler auf der Produktseite.
    Es kann kein Artikel in den Warenkorb gelegt werden und auch das Loginfenster ist ohne Funktion.

    Es betrifft die gm_javascript.js.php in Zeile 463:4 im Template EyeCandy

    Alle Dateien wurden ausgetauscht.

    Kennt jemand diese Fehlermeldung.

    https://vr-one.eu

    Danke und viele
    Grüße
    OB
     
  2. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    22. Juni 2011
    Beiträge:
    4.394
    Danke erhalten:
    1.572
    Danke vergeben:
    115
    Wenn du uns noch verrätst, wo wir deinen Shop finden, können wir eventuell mehr dazu rausfinden. :)
     
  3. easy-entertain

    easy-entertain Aktives Mitglied

    Registriert seit:
    21. Januar 2015
    Beiträge:
    26
    Danke erhalten:
    0
    Danke vergeben:
    4
    Beitrag editiert
     
  4. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.329
    Danke erhalten:
    2.380
    Danke vergeben:
    776
    In der JavaScript-Datei ist eine Fehlermeldung, dass die Datei
    templates/EyeCandy/javascript/product_info/PayPalButton.js fehlt.
     
  5. easy-entertain

    easy-entertain Aktives Mitglied

    Registriert seit:
    21. Januar 2015
    Beiträge:
    26
    Danke erhalten:
    0
    Danke vergeben:
    4
    Danke für den Tip,

    wo kommt dieses Fragment her?
    Ich habe alle Updates erfolgreich bis 2.7.4.2. ausgeführt und dann alle Dateien neu aus dem 2.7.4.2.full hochgeladen.
    Klemmen da ggf noch Änderungen in der Datenbank die auf alte Dateien verweisen?

    Vielen Dank,
    Gruß EE
     
  6. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.329
    Danke erhalten:
    2.380
    Danke vergeben:
    776
    Hallo,

    die Datei gehört zum paypalng Modul und wird standardmäßig nicht ausgeliefert, jedoch auch nicht gelöscht (soweit ich weiß), wenn man in einer älteren Shopversion paypalng genutzt hat. Jedenfalls sollte die Datei nicht mehr eingebunden werden, wenn du das paypalng-Modul deaktivierst. Es sollte das neuere paypal3 Modul genutzt werden.
     
  7. easy-entertain

    easy-entertain Aktives Mitglied

    Registriert seit:
    21. Januar 2015
    Beiträge:
    26
    Danke erhalten:
    0
    Danke vergeben:
    4
    Das PayPalIng war mal eingebunden, und ist nicht mehr eingebunden. Aktiv ist PayPal3. Mir scheint als wäre das ein Fragment.
    Wie hast du gesehen, das diese Datei fehlt templates/EyeCandy/javascript/product_info/PayPalButton.js ?
    Über den debugmodus konnte ich das nicht feststellen.

    Diese Date habe ich jetzt hinzugefügt, aber es geht immer noch nicht

    Vielen Dank,
    EE
     
  8. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.329
    Danke erhalten:
    2.380
    Danke vergeben:
    776
    Ich hatte mit den Quellcode der gm_javascript.js.php angeschaut, die am Ende der Seite eingebunden wird. Dort war eine entsprechende Fehlermeldung zu sehen. Die PayPalButton.js wird nur eingebunden, wenn das Modul aktiv ist. Vermutlich hast du noch einen Rest an Moduldaten in der Datenbank samt dem Aktiv-Status. In der configuration-Tabelle sollte es keinen Treffer für
    MODULE_PAYMENT_PAYPALNG_STATUS mit dem Wert True geben.
     
  9. easy-entertain

    easy-entertain Aktives Mitglied

    Registriert seit:
    21. Januar 2015
    Beiträge:
    26
    Danke erhalten:
    0
    Danke vergeben:
    4
    Hallo Moritz,

    genau das war das Problem. Das Modul war in der Datenbank noch aktiv. Ich habe es mit dem Status "false" versehen und jetzt geht das jquery wieder wunderbar.

    Vielen Dank,
    Gruß,
    EE
     
  10. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.329
    Danke erhalten:
    2.380
    Danke vergeben:
    776
    False statt false sollte es sein, damit es für den Shop gültig ist und später keine Probleme macht. Diese Schreibweise ist noch ein Relikt aus dem alten xtc-Shop, auf dem Gambio basiert.
     
  11. Manni_HB

    Manni_HB G-WARD 2012/13/14/15

    Registriert seit:
    26. April 2011
    Beiträge:
    9.098
    Danke erhalten:
    1.538
    Danke vergeben:
    908
    Ort:
    Bremen
    Upps - generell, immer & überall?
     
  12. easy-entertain

    easy-entertain Aktives Mitglied

    Registriert seit:
    21. Januar 2015
    Beiträge:
    26
    Danke erhalten:
    0
    Danke vergeben:
    4
    Auf False gestellt.
    Danke für den Hinweis!
     
  13. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.329
    Danke erhalten:
    2.380
    Danke vergeben:
    776
    Nein, nicht immer und überall. Ich sehe grade, dass es wirklich ganz bunt gemischt ist und vielmals auch keinen Fehler verursacht, wenn man die Groß- und Kleinschreibung nicht beachtet. Wenn man selber neue Optionen einführt ist es klein geschrieben auf jeden Fall schöner.