Update auf GX3.14.0.3 nicht möglich

Thema wurde von petra_engl, 5. Mai 2020 erstellt.

  1. petra_engl

    petra_engl Mitglied

    Registriert seit:
    22. April 2017
    Beiträge:
    22
    Danke erhalten:
    0
    Danke vergeben:
    4
    Liebes Team,

    Ich habe bereits mehrfach das gesamte Service Pack neu hochgeladen und bekomme immer diese Fehlermeldung:

    Das Service Pack wurde nicht vollständig hochgeladen. Bitte laden Sie das gesamte Service Pack noch einmal auf Ihren Webserver
    • GXMainComponents/Extensions/Orders/OrdersOverviewColumns.inc.php
    • GXMainComponents/Shared/SearchConditions/CategorySearchCondition.inc.php
    • images/flags/4x3/co.svg
    Auch mein Versuch diese 3 Dateien einzeln hochzuladen hat nichts geändert.

    Ich bitte dringend um Hilfe, da mein Shop natürlich dadurch offline ist.

    Liebe Grüße
    Petra
     
  2. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.203
    Danke erhalten:
    6.550
    Danke vergeben:
    1.997
    Lösch die alten Dateien auf dem Server, lad die dann neu hoch. Wenns dann nicht klappt bitte ein Ticket.
     
  3. petra_engl

    petra_engl Mitglied

    Registriert seit:
    22. April 2017
    Beiträge:
    22
    Danke erhalten:
    0
    Danke vergeben:
    4
    Jetzt hänge ich leider schon wieder fest.

    Nach dem Update auf 4.0.0.1 bleibt das Update immer an der Stelle stecken wo die Caches neu aufgebaut werden. Hänge hier schon das zweite Mal 1 Stunde. Wenn ich dennoch den Shop aufrufe kommt folgende Fehlermeldung:

    Fatal error: Uncaught TypeError: Argument 1 passed to ThemeControl::__construct() must be an instance of ViewSettings, instance of CI_DB_mysqli_driver given, called in /home/.sites/33/site1405649/web/system/core/MainFactory.inc.php(503) : eval()'d code on line 1 and defined in /home/.sites/33/site1405649/web/GXMainComponents/View/ThemeControl/ThemeControl.inc.php:149 Stack trace: #0 /home/.sites/33/site1405649/web/system/core/MainFactory.inc.php(503) : eval()'d code(1): ThemeControl->__construct(Object(CI_DB_mysqli_driver), 'Honeygrid') #1 /home/.sites/33/site1405649/web/system/core/MainFactory.inc.php(503): eval() #2 /home/.sites/33/site1405649/web/system/core/MainFactory.inc.php(287): MainFactory::create_object('ThemeControl', Array) #3 /home/.sites/33/site1405649/web/GXMainComponents/Loaders/GXCoreLoader/GXCoreLoader.inc.php(727): MainFactory::create('ThemeControl', Object(CI_DB_mysqli_driver), 'Honeygrid') #4 /home/.sites/33/site1405649/web/GXMainComponents/Loaders/GXCoreLoader/StaticGXCoreLoader.inc.php(138): GXCoreL in /home/.sites/33/site1405649/web/GXMainComponents/View/ThemeControl/ThemeControl.inc.php on line 149 Fatal error: Uncaught TypeError: Argument 1 passed to ThemeControl::__construct() must be an instance of ViewSettings, instance of CI_DB_mysqli_driver given, called in /home/.sites/33/site1405649/web/system/core/MainFactory.inc.php(407) : eval()'d code on line 1 and defined in /home/.sites/33/site1405649/web/GXMainComponents/View/ThemeControl/ThemeControl.inc.php:149 Stack trace: #0 /home/.sites/33/site1405649/web/system/core/MainFactory.inc.php(407) : eval()'d code(1): ThemeControl->__construct(Object(CI_DB_mysqli_driver), 'Honeygrid') #1 /home/.sites/33/site1405649/web/system/core/MainFactory.inc.php(407): eval() #2 /home/.sites/33/site1405649/web/system/core/MainFactory.inc.php(287): MainFactory::create_object('ThemeControl', Array) #3 /home/.sites/33/site1405649/web/GXMainComponents/Loaders/GXCoreLoader/GXCoreLoader.inc.php(727): MainFactory::create('ThemeControl', Object(CI_DB_mysqli_driver), 'Honeygrid') #4 /home/.sites/33/site1405649/web/GXMainComponents/Loaders/GXCoreLoader/StaticGXCoreLoader.inc.php(138): GXCoreL in /home/.sites/33/site1405649/web/GXMainComponents/View/ThemeControl/ThemeControl.inc.php on line 149
     
  4. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    31.860
    Danke erhalten:
    9.776
    Danke vergeben:
    1.442
    Das Update ist an der Stelle durch.
    gehe in den Admin-bereich und leere dort einmal die Cache von unten nach oben.
     
  5. petra_engl

    petra_engl Mitglied

    Registriert seit:
    22. April 2017
    Beiträge:
    22
    Danke erhalten:
    0
    Danke vergeben:
    4
    Das geht nicht, ich kann meinen Shop nicht aufrufen, wie schon oben erwähnt, kommt dann die Fatal error Meldung
     
  6. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    31.860
    Danke erhalten:
    9.776
    Danke vergeben:
    1.442
    Versuch es mal mit
    DeineDomain/login_admin.php
    (Deine Domain mit Deiner Domain ersetzten)

    und danach mit
    DeineDomain/admin/clear_cache.php
     
  7. petra_engl

    petra_engl Mitglied

    Registriert seit:
    22. April 2017
    Beiträge:
    22
    Danke erhalten:
    0
    Danke vergeben:
    4
    Leider geht beides nicht, lande immer wieder bei der oben genannten Fehlermeldung
     
  8. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    31.860
    Danke erhalten:
    9.776
    Danke vergeben:
    1.442
    Hast Du schon mal den Browsercache geleert? da könnte auch etwas kleben.
    Wenn das nciht hilft, Ticket an Gambio
     
  9. petra_engl

    petra_engl Mitglied

    Registriert seit:
    22. April 2017
    Beiträge:
    22
    Danke erhalten:
    0
    Danke vergeben:
    4
    Hab ich auch schon gemacht, leider ebenfalls ohne Erfolg. Danke vielmals, ich öffne ein Ticket