Update von 3.15.3.1 auf 4.x

Thema wurde von holger_munding, 12. Oktober 2020 erstellt.

  1. holger_munding

    holger_munding Neues Mitglied

    Registriert seit:
    31. Dezember 2018
    Beiträge:
    3
    Danke erhalten:
    0
    Update auf die aktuellste Version (3.15.3.0 auf 4.2.0.0)

    Im Moment läuft mein shop mit V.3.15..1
    Im Kundenportal bekomme ich folgende zum Download angeboten:
    Master Update v4.0.0.1 (GX4) 24,89 MB - 26.03.20
    Master Update v4.2.0.0 (GX4) 38,3 MB - 16.09.20
    Welches kann ich bedenkenlos auf meine Version einspielen und sind Probleme zu erwarten?
    Ich möchte natürlich nicht dass ich plötzlich keinen Zugriff mehr habe oder ähnliches.
    (hab hier schon von einigen Problemen gelesen)
    Leider bin ich nicht gerade "Exoerte".
    viele Grüße
    Holger
     
  2. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.207
    Danke erhalten:
    6.552
    Danke vergeben:
    1.997
    Wichtiger Hinweis: Die sind nicht 100% alternativ zueinander, sondern haben eine nötige Reihenfolge. Master Update 4.2.0.x unterstützt keinen Shop kleiner als mindestens 4.0.0.0.

    Das heisst:
    Wenn du das Masterupdate 4.2.0.x direkt auf deinen 3.15.x.x spielst ist der kaputt, wenn du nicht vorher mit Master Update 4.0.0.x das nötige Zwischenupdate machst.
     
  3. holger_munding

    holger_munding Neues Mitglied

    Registriert seit:
    31. Dezember 2018
    Beiträge:
    3
    Danke erhalten:
    0
    Also kann ich das Master Update v4.0.0.1 (GX4) 24,89 MB - 26.03.20 bedenkenlos auf meine 3.15.1 aufspielen? Oder muss ich mir erst das 4.0.0.0 besorgen?
     
  4. Ralf von SC

    Ralf von SC Erfahrener Benutzer

    Registriert seit:
    3. Juni 2019
    Beiträge:
    229
    Danke erhalten:
    26
    Danke vergeben:
    12
    ja das kannst Du und danach das Masterupdate 4.2.0.x
     
  5. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.207
    Danke erhalten:
    6.552
    Danke vergeben:
    1.997
    Bei jedem Update ist im Downloadbereich angegeben, zu welchen Versionen es kompatibel ist. Wenn eine Angabe unklar sein sollte oder merkwürdig erscheint: Immer hier oder per Ticket nachfragen.

    Wenn bei einem Update nur die letzte Stelle hochzählt, ersetzt das Paket ein anderes, älteres. 4.0.0.1 ist damit eine Ersetzung von 4.0.0.0. 4.0.0.0 wird dann von uns nicht mehr angeboten. Der Unterschied sind meist einige, wenige Bugfixes.
     
  6. holger_munding

    holger_munding Neues Mitglied

    Registriert seit:
    31. Dezember 2018
    Beiträge:
    3
    Danke erhalten:
    0
    Danke Wilken und Ralf von SC
     
  7. markus_wick

    markus_wick Erfahrener Benutzer

    Registriert seit:
    10. Oktober 2018
    Beiträge:
    641
    Danke erhalten:
    110
    Danke vergeben:
    90
    Am ehesten sind Probleme mit Externen Modulen und Theme-Anpassungen zu erwarten. War zumindest bei mir bei einem Test des Updates von 3.14.3.0 auf 4.2.0.0 der Fall.
     
  8. markus_wick

    markus_wick Erfahrener Benutzer

    Registriert seit:
    10. Oktober 2018
    Beiträge:
    641
    Danke erhalten:
    110
    Danke vergeben:
    90
    Und wenn Du einen Support-Vertrag hast, kannst Du Dir im Support-Bereich auch ein Update-Paket zusammenstellen lassen, dass das Update auf die neueste Version in einem Rutsch erledigt.
    Das heisst dann z.B. so: KU v3.14.3.0 auf v4.2.0.0.zip und enthält alles was nötig ist. Hat bei mir beim letzten Test erstaunlich reibungslos geklappt.