v3.6.x versendete Emails kommen sporadisch nicht an

Thema wurde von saschadd, 13. Dezember 2017 erstellt.

  1. saschadd

    saschadd Erfahrener Benutzer

    Registriert seit:
    24. März 2015
    Beiträge:
    216
    Danke erhalten:
    14
    Danke vergeben:
    28
    Hallo,

    wir sind auf Version v3.6.2.0 und haben momentan das Problem, dass die vom Shop automatisch versendeten Emails teilweise nicht ankommen. Es ist uns jetzt speziell bei den Bestellbestätigungen aufgefallen, welche wir teilweise nicht bekommen. Im Shop werden diese als versendet angezeigt und bei den Emails im Shop seh ich die auch.
    Gibt es ein Email-Log, wo ich nachschauen könnte wo das Problem ist?
     
  2. saschadd

    saschadd Erfahrener Benutzer

    Registriert seit:
    24. März 2015
    Beiträge:
    216
    Danke erhalten:
    14
    Danke vergeben:
    28
    Ich hab selbst nochmal drübergeschaut, es sieht so aus, als ob an den Kunden die Bestellbestätigung rausgeht aber nicht die an uns.
     
  3. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    2. Dezember 2012
    Beiträge:
    586
    Danke erhalten:
    69
    Danke vergeben:
    238
    Das war bei uns auch und aktuell wieder bei einer Bestellung.
     
  4. Developer

    Developer Erfahrener Benutzer

    Registriert seit:
    7. November 2012
    Beiträge:
    2.646
    Danke erhalten:
    535
    Danke vergeben:
    92
    Aktuell ist mir kein Bug bekannt. Mag mich aber auch irren.

    Seit wann habt ihr das Problem?
    Seid Ihr immer noch beim selben Provider?
    Welche Versandmethode bei den E-Mails ist gewählt?
    Die PHP-Version ist gleich geblieben?

    Ein paar nähere Infos wären schön. :)
     
  5. saschadd

    saschadd Erfahrener Benutzer

    Registriert seit:
    24. März 2015
    Beiträge:
    216
    Danke erhalten:
    14
    Danke vergeben:
    28
    Ich bin mir noch nicht 100% sicher, glaube aber, dass es nur mit yahoo und aol Adressen Probleme gibt.

    Ich hatte den Emailversand auf SMTP über TLS, da es in der Vergangenheit mit sendmail und mail mal Probleme gab.
    Jetzt tritt der Fehler komischerweise mit SMTP auch auf.
    Ich vermute im Moment, dass unser Mailserver (bei Strato) die yahoo und aol Absender nicht annimmt, da die Emails ja nur vorgegaugelt von den Emailadressen direkt kommen.

    Die PHP-Version ist bei uns schon eine ganze Weile auf 7.0.x
    Provider wurde nicht gewechselt.
     
  6. saschadd

    saschadd Erfahrener Benutzer

    Registriert seit:
    24. März 2015
    Beiträge:
    216
    Danke erhalten:
    14
    Danke vergeben:
    28
    Ich hatte probehalber auf sendmail und mail umgestellt, das funktioniert auch nicht.
    Wenn ich jetzt aber wieder auf smtp.strato.de umstelle, dann bekomm ich einen "smtp_connect_failed" Fehler.
    Das dürfte dann wohl den Fehler erklären.
    Ich hab hier zum Testen eine Bestellbestätigung an den Kunden im Shop angeschaut, Absender und Empfänger vertauscht und gesendet. Das dürfte ja dann eine Bestellbestätigung an uns sein.
     
  7. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    2. Dezember 2012
    Beiträge:
    586
    Danke erhalten:
    69
    Danke vergeben:
    238
    Heute Bestellung um 10:22 Bestellbestätigung an uns erhalten
    Heute Bestellung um 11:49 Bestellbestätigung an uns nicht erhalten
     
  8. Developer

    Developer Erfahrener Benutzer

    Registriert seit:
    7. November 2012
    Beiträge:
    2.646
    Danke erhalten:
    535
    Danke vergeben:
    92
    Ich denke, Du hast ein anderes Problem und es ist nur eine Einstellsache.

    Nur nochmal zum Verständnis: Das Problem musst Du ja schon immer gehabt haben, oder?

    Weil sonst gibt es nur eine Erklärung dafür: Entweder technische Änderung seitens deinem Shop, was die Version betrifft oder dein Hoster.

    Im Worst-Case-Szenario geht SMTP immer. Dazu müssen aber auch die Einstellungen exakt stimmen. Sonst führt dies auch zu Problemen.
     
  9. saschadd

    saschadd Erfahrener Benutzer

    Registriert seit:
    24. März 2015
    Beiträge:
    216
    Danke erhalten:
    14
    Danke vergeben:
    28
    Okay, ich hab mal weiter getestet:

    Einstellung ist auf mail

    ich sende von unserem shop an unsere bei strato liegende Emailadresse > kommt nicht an
    ich sende von unserem shop an unsere bei all-inkl liegende Emailadresse > kommt an

    Bei der vorherigen SMTP Einstellung war das sendende Emailkonto mit dem empfangenden Emailkonto identisch.
    Ist das möglicherweise eine Fehlerquelle? Werde nachher nochmal testen dem Shop eine eigene Sende-Emailadresse zu verpassen.
     
  10. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    2. Dezember 2012
    Beiträge:
    586
    Danke erhalten:
    69
    Danke vergeben:
    238
     
  11. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    2. Dezember 2012
    Beiträge:
    586
    Danke erhalten:
    69
    Danke vergeben:
    238
    Nein.
     
  12. saschadd

    saschadd Erfahrener Benutzer

    Registriert seit:
    24. März 2015
    Beiträge:
    216
    Danke erhalten:
    14
    Danke vergeben:
    28
    Ich hab jetzt eine Lösung gefunden:
    Bei den Email-Einstellungen gibt es einen Punkt

    Absender der Bestellbestätigungsmail

    wenn ich den auf "Betreiber-Email" umstelle, dann wird in den Absender unsere eigene Emailadresse eingefügt und bei "Antwort an" die des Kunden. Damit sollte das Problem gelöst sein.
    Ich werd mal beobachten und nochmal Rückmeldung geben.
     
  13. Developer

    Developer Erfahrener Benutzer

    Registriert seit:
    7. November 2012
    Beiträge:
    2.646
    Danke erhalten:
    535
    Danke vergeben:
    92
    Alles klar. :)
     
  14. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    2. Dezember 2012
    Beiträge:
    586
    Danke erhalten:
    69
    Danke vergeben:
    238
    Wir haben jetzt auch auf "Betreiber Email" umgestellt und bekommen trotzdem keine Benachrichtigungs Mail bei eingegangener Bestellung. Der Status im Gambio Backend bei den Emails steht auf "gesendet".
     
  15. Developer

    Developer Erfahrener Benutzer

    Registriert seit:
    7. November 2012
    Beiträge:
    2.646
    Danke erhalten:
    535
    Danke vergeben:
    92
    Bei welchem Priovider bist Du, Tosula?
     
  16. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    2. Dezember 2012
    Beiträge:
    586
    Danke erhalten:
    69
    Danke vergeben:
    238
    Die Email Adressen liegen bei Strato, der Shop ist bei Estugo gehostet.
     
  17. Anonymous

    Anonymous Beta-Held

    Registriert seit:
    22. März 2015
    Beiträge:
    2.381
    Danke erhalten:
    640
    Danke vergeben:
    412
    Hast du die SMTP Einstellungen von Strato oder Estugo?
     
  18. Dennis (MotivMonster.de)

    Dennis (MotivMonster.de) G-WARD 2013/14/15/16

    Registriert seit:
    22. September 2011
    Beiträge:
    30.416
    Danke erhalten:
    5.917
    Danke vergeben:
    1.060
    Beruf:
    Mann für alles :)
    Ort:
    Weilburg
    Hast mal in Spam Filter geschaut bei dir?
     
  19. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    2. Dezember 2012
    Beiträge:
    586
    Danke erhalten:
    69
    Danke vergeben:
    238
    Strato
     
  20. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    2. Dezember 2012
    Beiträge:
    586
    Danke erhalten:
    69
    Danke vergeben:
    238
    Ja