WARNING(2): "Use of undefined constant MH_CIS_URL

Thema wurde von wolfgang_schatz, 20. August 2018 erstellt.

  1. wolfgang_schatz

    wolfgang_schatz Erfahrener Benutzer

    Registriert seit:
    26. August 2017
    Beiträge:
    74
    Danke erhalten:
    4
    Danke vergeben:
    14
    Hallo,
    habe gerade probeweise die PHP-Version auf 7.2 (7.2.8) umgestellt.
    Jetzt kommt beim Shopaufruf die Warnung:

    WARNING(2): "Use of undefined constant MH_CIS_URL - assumed 'MH_CIS_URL' (this will throw an Error in a future version of PHP)"

    "Rückzug" auf 7.1 entfernt die Warnung reproduzierbar.
    Ist der Shop noch nicht für 7.2 bereit oder ist in meinem Shop was nicht so wie es sein soll?


    Gruß,
    Wolfgang
     
  2. Torben Wark

    Torben Wark Gambio GmbH

    Registriert seit:
    15. Juli 2014
    Beiträge:
    2.581
    Danke erhalten:
    1.175
    Danke vergeben:
    399
    Hast du Mailbeez aktiv? Das könnte das Problem sein. Ich bin mir gerade nicht sicher, ob das inziwschen PHP 7.2 kompatibel ist.
     
  3. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.782
    Danke erhalten:
    6.759
    Danke vergeben:
    2.048
    Mailbeez hat noch Probleme mit PHP7.2, Cord sagt er arbeitet daran.
     
  4. wolfgang_schatz

    wolfgang_schatz Erfahrener Benutzer

    Registriert seit:
    26. August 2017
    Beiträge:
    74
    Danke erhalten:
    4
    Danke vergeben:
    14
    Ok, das ging ja echt schnell. Ja, ich verwende Mailbeez für die Shopbewertungen. Gibt es da Alternativen?
    Gruß und vielen Dank,
    Wolfgang
     
  5. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.782
    Danke erhalten:
    6.759
    Danke vergeben:
    2.048
    Natürlich: Shopvote, Trusted Shops,.... da sind wirklich viele unterwegs. Ich würde aber persönlich noch nen Moment mit PHP7.1 fahren für durchaus legitim halten. Das wird noch aktiv gepflegt und ist fast genauso performant wie PHP7.2.
     
  6. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    13. November 2018
    Beiträge:
    129
    Danke erhalten:
    3
    Danke vergeben:
    19
    Hi, ich habe leider auch das Problem bei lokaler Neuinstalltation von GX3.11 neuste Version. Folgende Warnmeldungen siehe anhang. Shop ist lokal unter xampp und windows installiert. was kann ich tun?
     
  7. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    13. November 2018
    Beiträge:
    129
    Danke erhalten:
    3
    Danke vergeben:
    19
    Hi, ich habe leider auch das Problem bei lokaler Neuinstalltation von GX3.11 neuste Version. Folgende Warnmeldungen Use of undefined constant in Header, Text Guest und vielen anderen.
    Shop ist lokal unter xampp und windows installiert. was kann ich tun? Bei der shop 3.10 version hatte ich das nicht.
    Kann mir bitte jemand helfen? Vielen Dank.
     

    Anhänge:

  8. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.782
    Danke erhalten:
    6.759
    Danke vergeben:
    2.048
    Das ist kein 3.11, das sehe ich am Aussehen.
     
  9. Guyonthecouch

    Guyonthecouch Erfahrener Benutzer

    Registriert seit:
    17. September 2016
    Beiträge:
    203
    Danke erhalten:
    24
    Danke vergeben:
    85
    Moin Moin,
    ich würde das Thema gerne erneut aufleben lassen. Wir haben aktuell PHP-Version 7.1.33 am laufen und bekommen die o.g. Fehlermeldung.

    WARNING(2): "Use of undefined constant MH_CIS_URL - assumed 'MH_CIS_URL' (this will throw an Error in a future version of PHP)"

    Gibt es evtl. eine Möglichkeit diese zu unterdrücken? Gibt es schon einen Fix?
    Leider kann ich Mailbeez (nutze ich lediglich für Bewertungen) nicht über das System updaten, da ich eine Menge Fehler geworfen bekomme.

    WARNING(2): "Use of undefined constant MH_CIS_URL - assumed 'MH_CIS_URL' (this will throw an Error in a future version of PHP)"
    WARNING(2): "Use of undefined constant DISPLAY_REQUEST_PROFILER - assumed 'DISPLAY_REQUEST_PROFILER' (this will throw an Error in a future version of PHP)"
    WARNING(2): "Use of undefined constant DISPLAY_REQUEST_PROFILER - assumed 'DISPLAY_REQUEST_PROFILER' (this will throw an Error in a future version of PHP)"
    WARNING(2): "Use of undefined constant DISPLAY_REQUEST_PROFILER - assumed 'DISPLAY_REQUEST_PROFILER' (this will throw an Error in a future version of PHP)"
    WARNING(2): "Use of undefined constant DISPLAY_REQUEST_PROFILER - assumed 'DISPLAY_REQUEST_PROFILER' (this will throw an Error in a future version of PHP)"
    WARNING(2): "Cannot modify header information - headers already sent by (output started at /var/www/vhosts/xxx/gm/classes/ErrorHandler.php:419)"

    Vielen Dank und Grüße
     
  10. FRAGO

    FRAGO Erfahrener Benutzer

    Registriert seit:
    5. Dezember 2019
    Beiträge:
    779
    Danke erhalten:
    242
    Danke vergeben:
    100
    gib doch mal ein paar Eckdaten bekannt...

    Shop Version, seit Wann ist der Fehler, welche Fremdmodule sind installiert .....
     
  11. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.782
    Danke erhalten:
    6.759
    Danke vergeben:
    2.048
    Ein Update von Mailbeez ist aber die Lösung... Das Updateproblem muss also gelöst werden.