Modul Automatische Versandberechnung 7% / 19%

Thema wurde von Steffen (indiv-style.de), 28. November 2014 erstellt.

  1. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    30. Juni 2017
    Beiträge:
    168
    Danke erhalten:
    16
    Danke vergeben:
    19
    So weit so gut. Spannend wird das aber erst wenn sich in einem Paket Waren mit unterschiedlichen USt-Klassen befinden, also beispielsweise ein Buch und eine DVD. Dann soll in Abhängigkeit vom Warenwert auch auf die Verpackungs- und Versandkosten anteilig der jeweilige der USt-Steuersatz der Waren angewendet werden. Um bei unserem Beispiel Buch/DVD zu bleiben: Ist das Buch 60% wert und die DVD 40%, müssen die Versandkosten gesplittet werden: Für 60% gilt der 7%ige USt-Satz und für 40% der 19%ige USt-Satz.

    Macht das dein Modul auch?
     
  2. barbara

    barbara G-WARD 2014/15/16

    Registriert seit:
    14. August 2011
    Beiträge:
    29.679
    Danke erhalten:
    8.947
    Danke vergeben:
    1.330
    Ich habe hier einen Artikel mit 3€ und 19%, und einen Artikel mit 6,90 und 7%
    Unbenannt.JPG
    Die MwSt der Versandkosten werden genau danach aufgeteilt
     
  3. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    30. Juni 2017
    Beiträge:
    168
    Danke erhalten:
    16
    Danke vergeben:
    19
    Na, dann sollte alles Bestens sein. ;)
     
  4. Anonymous

    Anonymous Mitglied

    Registriert seit:
    16. Mai 2017
    Beiträge:
    21
    Danke erhalten:
    0
    Danke vergeben:
    5
    Hallo!

    Ich habe den/das/die Zip in meinen 3.6er eingebaut (Danke!) und es funktioniert scheinbar.
    Allerdings missfällt mir minimal die Schreibweise von Eur, hätte es gern EUR genannt, aber Datei ändern und neu hochladen, deinstallieren und installieren, Cache leeren usw. bewirkt keine Änderungen. Wo muss ich Änderungen durchführen?

    In der Bestellbestätigungsmail (Text-Format) werden die Leerzeichen zwischen den Versandkostenmehrwertsteuerangaben mit diesen geschützten Leerzeichen ausgegeben:

    Zwischensumme: 154,95 EUR
    Pauschale Versandkosten (Standard): 6,00 EUR
    inkl. 7% MwSt.: 0,98 EUR
    inkl. 19% MwSt.: 14,37 EUR
    inkl. 7% MwSt auf Versandkosten = 0.04 Eur19% MwSt auf Versandkosten =
    0.56 Eur0% MwSt auf Versandkosten = 0 Eur: 0,59 EUR
    Summe netto: 145,01 EUR
    Summe: 160,95 EUR


    Wie bzw. wo bekomme ich die weg?

    Dann gibt es bei obiger Rechnung auch einen Rundungsfehler: 0,04 EUR + 0,56 EUR + 0 EUR = 0,59 EUR
    Ich weiß nicht wie oft es zu solchen Rundungsfehlerchen kommen kann, vermutlich eher selten, aber kann man irgendwo einstellen, dass die Angabe nicht irritiert, falls doch mal jemand nachrechnet?

    Würde mich über Tipps sehr freuen!

    Viele Grüße
    Claudia
     
  5. Anonymous

    Anonymous Mitglied

    Registriert seit:
    29. Januar 2018
    Beiträge:
    10
    Danke erhalten:
    0
    Funktioniert das Modul im aktuellen GX 3.12 auch noch?
    Echt peinlich, dass Gambio das nicht von Haus aus kann....
     
  6. barbara

    barbara G-WARD 2014/15/16

    Registriert seit:
    14. August 2011
    Beiträge:
    29.679
    Danke erhalten:
    8.947
    Danke vergeben:
    1.330
    ja, läuft
     
  7. Anonymous

    Anonymous Mitglied

    Registriert seit:
    29. Januar 2018
    Beiträge:
    10
    Danke erhalten:
    0
    #67 Anonymous, 23. Mai 2019
    Zuletzt bearbeitet: 23. Mai 2019
    Hallo. Danke für das tolle Modul. Habe leider ein Problem:
    "inkl.19% MwSt auf Versandkosten = 16.29 EUR: 13,23 EUR"
    Versand Beispiel 99 EUR. Steuer müsste 15,81 EUR sein. Die Differenz zu 16,29 sind genau die 3% Vorkasse-Rabat. Kann es sein, dass die nicht zusammenarbeiten? Im Modul Vorkasse-Rabatt ist es deaktiviert die Versandgebühr mit zu rabattieren.

    Wenn man "Neuberechnung der MwSt" deaktiviert, funktioniert es, aber dann stimmt natürlich die Netto-Summe nicht mehr.
     
  8. Anonymous

    Anonymous Mitglied

    Registriert seit:
    29. Januar 2018
    Beiträge:
    10
    Danke erhalten:
    0
    Niemand eine Idee? :(
     
  9. Bernd Voß

    Bernd Voß Erfahrener Benutzer

    Registriert seit:
    6. Januar 2014
    Beiträge:
    114
    Danke erhalten:
    1
    Danke vergeben:
    42
    Habe versucht es in einem 3.15er Testshop zu installieren. Allerdings erscheint beim SQL Schritt folgende Fehlermeldung bei mir. Hat jemand eine Idee?

    Error: Table 'blabla.language_section_phrases' doesn't exist
     
  10. barbara

    barbara G-WARD 2014/15/16

    Registriert seit:
    14. August 2011
    Beiträge:
    29.679
    Danke erhalten:
    8.947
    Danke vergeben:
    1.330
    Ich teste mal.
     
  11. barbara

    barbara G-WARD 2014/15/16

    Registriert seit:
    14. August 2011
    Beiträge:
    29.679
    Danke erhalten:
    8.947
    Danke vergeben:
    1.330
  12. barbara

    barbara G-WARD 2014/15/16

    Registriert seit:
    14. August 2011
    Beiträge:
    29.679
    Danke erhalten:
    8.947
    Danke vergeben:
    1.330
    Ist ganz simpel - man muss nur darauf kommen.
    Der Ordner GXUserComponents ist weg - oder sollte weg sein, was er in meinem Testshop nicht ist.

    Die Datei, die bisher in GXUserComponents/overloads/ot_shipping/
    liegt, muss jetzt in
    GXModules/Meins/MwSt-Versand/Shop/Overloads/ot_shipping/

    statt "Meins" könnt ihr Euren Namen oder Kürzel verwenden und statt "MwSt-Versand" einen anderen Namen für die Funktion.

    Nach dem Hochladen einmal im Admin unter Module -> Zusammenfassung die Versandkosten (ot_shipping) deinstallieren
    dann den Cache für Texte, Module und Seiten (von unten nach oben) leeren und danach die Versandkosten (ot_shipping) installieren.
     
  13. Bernd Voß

    Bernd Voß Erfahrener Benutzer

    Registriert seit:
    6. Januar 2014
    Beiträge:
    114
    Danke erhalten:
    1
    Danke vergeben:
    42
    Vielen Vielen Dank :) Es funktioniert. Einfach toll wie Du dich in jedes Problem mit reindenkst und hilfst es zu lösen
     
  14. barbara

    barbara G-WARD 2014/15/16

    Registriert seit:
    14. August 2011
    Beiträge:
    29.679
    Danke erhalten:
    8.947
    Danke vergeben:
    1.330
    Bisher hat dieses tolle Modul von Steffen einwandfrei funktioniert.
    Aber mit der Umstellung der MwSt kommt das bei mir nicht klar.
    mir werden immer 2 unterschiedliche Werte angezeigt:
    Beispiel bei 7.00€ Versandkosten:
    Unbenannt.JPG

    Das müssten eigentlich 0,97€ MwSt sein, und nicht 0,99 - aber davon werden nochmal 16% abgezogen

    Bei einem gemischten WK mit 16% und 5 % ist es noch schlimmer
    Versandkosten 6€ (Der Warenwert mit 16% und 5% ist identisch)
    Unbenannt-1.JPG

    da werden offenbar 21% abgezogen
     
  15. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    12. Februar 2014
    Beiträge:
    199
    Danke erhalten:
    38
    Danke vergeben:
    190
    Ich kann da nur dieses Modul empfehlen, funktioniert einwandfrei:

    (Link nur für registrierte Nutzer sichtbar.)
     
  16. barbara

    barbara G-WARD 2014/15/16

    Registriert seit:
    14. August 2011
    Beiträge:
    29.679
    Danke erhalten:
    8.947
    Danke vergeben:
    1.330
    Das Modul von Steffen hat bisher einwandfrei funktioniert - nur die Umstellung mag es gerade nicht.

    Bei mir fliegen die 7% Artikel raus - das ist (fast) nur noch ein Abverkauf. Dafür lohnt es sich nicht ein Modul zu kaufen.
    Auch wenn das bestimmt gut ist.
     
  17. barbara

    barbara G-WARD 2014/15/16

    Registriert seit:
    14. August 2011
    Beiträge:
    29.679
    Danke erhalten:
    8.947
    Danke vergeben:
    1.330
    Fehler (durch Zufall) gefunden, bzw. kann ich das eingrenzen.
    Das Modul funktioniert nicht, wenn man einen Kundengruppenrabatt auf die ganze Bestellung gibt.