Billbee - Gambio Cloud Verknüpfung

Thema wurde von Anonymous, 17. August 2021 erstellt.

  1. Anonymous

    Anonymous Mitglied

    Registriert seit:
    17. Mai 2020
    Beiträge:
    10
    Danke erhalten:
    0
    Hallo,


    Ich versuche gerade den Gambio Cloudshop mit Billbee zu verbinden, um an Daten für die Fibu zu kommen. Tipp habe ich im Forum mehrfach gelesen. Nun habe ich aber das Problem das ich, wenn ich die Verbindung zu Gambio Teste ein
    • 401 - Invalid Credentials
    bekomme. Laut Billbee Troubleshooting könnte das daran liegen:

    ----

    In der Regel liegt es an einer fehlenden Weiterleitung des HTTP BasicAuth Headers innerhalb des WebServers. Abhilfe schafft meistens ein Eintrag in der .htaccess Datei (im Hauptverzeichnis deines Shops zu finden) des Gambio Shops:
    Hinweis: Die .htaccess Datei ist eventuell auf manchen Systemen ausgeblendet, weshalb das System erst so konfiguriert werden muss, dass "verstecke/ausgeblendete Dateien und Ordner" ebenfalls angezeigt werden. Wie das im Detail geht, hängt vom Betriebssystem ab.
    RewriteRule ^(.*)api.php - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    Diese Zeile sollte in der .htaccess Datei unmittelbar nach Aktivierung des mod_rewrite, also direkt unter der Zeile "RewriteEngine on", aber nach einer eventuell gesetzten RewriteBase eingefügt werden. Danach muss die .htaccess Datei nur noch gespeichert und ggf. der Webserver neu gestartet werden.

    Hilft das auch nicht, ist noch zu prüfen, ob es sich bei dem Login um einen vollwertigen Admin Zugang handelt.


    -----


    Die Zugangsdaten habe ich gerade mit einem jungfräulichen Browser getestet. Der entsprechende Admin Account hat auch API Zugang. Zugriff auf die .htaccess habe ich ja mit dem Cloud-Shop nicht....


    Übersehe ich etwas?
     
  2. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    2. Mai 2012
    Beiträge:
    388
    Danke erhalten:
    163
    Danke vergeben:
    93
    Die Änderungen, die Billbee anspricht, sind in aktuellen Shopversionen wie den Cloud-Shops nicht mehr nötig. Zudem ist "401 - Invalid Credentials" recht eindeutig, prüfe einmal die Shop-Daten, die du bei Billbee hinterlegt hast. Dazu gehört auch die Shop-URL, diese muss mit der aktuellen übereinstimmen. Auch die Rechte des hinterlegten Adminkontos müssen stimmen.
     
  3. Anonymous

    Anonymous Mitglied

    Registriert seit:
    17. Mai 2020
    Beiträge:
    10
    Danke erhalten:
    0
    Eigentlich ist das wirklich recht eindeutig.

    Habe die Anmeldedaten in einen jungfräulichen Browser ausprobiert und kann mich damit im Shop anmelden mit dem Account der auch die API Freigabe hat.


    Versuche ich zu Fuß etwas wie hier unsershop.gambiocloud.com/api.php/v2/categories/1/products

    und gebe dann diese Anmeldedaten ein bekomme ich auch ein 401

    gibt es noch irgendeine Stellschraube, die das verursachen kann?

    Username ist doch die E-Mail des Admin-Benutzers mit API Zugang?
     
  4. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    2. Mai 2012
    Beiträge:
    388
    Danke erhalten:
    163
    Danke vergeben:
    93
    Check mal die Adminrechte für das Konto, für den API-Zugriff müssen die komplett erteilt werden.