gelöst Login & in Warenkorb legen am Testshop nicht möglich

Thema wurde von sirtet, 11. September 2020 erstellt.

  1. sirtet

    sirtet Erfahrener Benutzer

    Registriert seit:
    4. Juli 2012
    Beiträge:
    916
    Danke erhalten:
    78
    Danke vergeben:
    67
    Nach dem Anlegen eines Testshops läuft dieser noch nicht richtig:

    Zum einen, wenn man einen Artikel in den Warenkorb legen will, kommt dort nichts an. Das Popup am Warenkorb-Icon meldet "keine Artikel im Warenkorb".

    Zum anderen, wenn ich mich einloggen will, bekomme ich einfach die Anmeldeseite OHNE Fehlermeldung.
    Bei falschem Passwort wird dies moniert, bei richtigem nicht.

    Kommt das jemandem bekannt vor?
    Cache- und templates_c Verzeichnisse geleert...
     
  2. sirtet

    sirtet Erfahrener Benutzer

    Registriert seit:
    4. Juli 2012
    Beiträge:
    916
    Danke erhalten:
    78
    Danke vergeben:
    67
    Ach, gelöst:
    ich hatte die includes/configure.php von einem falschen Ort kopiert, da war HTTP_SERVER nicht auf https://
    und ENABLE_SSL false...

    Musste für mich so aussehen:
    PHP:
    define('HTTP_SERVER''https://www....
    define('
    HTTPS_SERVER', 'https://www...
    define('ENABLE_SSL'true); // 
    Danach ging login und warenkorb wieder, aber die admin Seiten waren weiss, bis auf den Button cm CRM Pad...
    [studier...] ah ja, gleiches in der admin/includes/configure.php

    PHP:
    define('HTTP_SERVER''https://www...
    define('
    HTTP_CATALOG_SERVER', 'https://www...
    define('ENABLE_SSL_CATALOG''true');