Meine Bilder bei Google

Thema wurde von Anonymous, 4. Juli 2016 erstellt.

  1. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    Hallo, also irgendwas ist mächtig schief gelaufen. Durch den anderen Beitrag hier im Forum (wo ich mal die Bildsuche aufrufen sollte) bin ich da erst drauf gestoßen. Bin ja nun eigentlich noch ein Neuling und habe bestimmt was falsch gemacht.

    Meine Bilder sind bei Google nur zum Teil indexiert. Wenn ich jetzt auf das Bild klicke, dann wird mein Shop aufgerufen, aber dort erscheint dann nicht der Artikel, sondern die Meldung "die Suche ergab keine genauen Treffer". Von 100 Bildern sind nur die neueren (von den letzten 2 Wochen) ok. Die meisten alten Bilder laufen ins Leere. Von 30 Klicks war gerade mal ein Treffer bei den alten Bildern dazwischen.

    Was habe ich nur falsch gemacht und wie kann ich bei Google erreichen, dass diese Bilder korrekt eingelesen werden?

    Dann ist klar warum niemand meinen Shop findet :(

    Ich würde mich wirklich freuen, wenn mir das jemand erklären könnte.

    Gruß Momo
     
  2. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.730
    Danke erhalten:
    10.491
    Danke vergeben:
    1.500
    Hast Du bei Google eine aktuelle Sitemap eingereicht?
    Hast Du die URLs noch mal geändert?
    Schau mal in die Webmaster Tools (Search Konsole) welche Artikel nciht gefunden werden.
     
  3. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    #3 Anonymous, 4. Juli 2016
    Zuletzt bearbeitet: 4. Juli 2016
    Vor 2 Tagen habe ich die Sitemap neu eingereicht. Die letzte war vor 2 Monaten. Ich hatte mal URLs geändert, aber das ist gut 4 Monate her. Ob es daran liegt? Ich schau mal und berichte dann.

    Edit: Also es werden 104 Seiten nicht gefunden. Das sind die, die ich umbenannt habe. Und dazu sind es größtenteils die Fotos.

    Und nun? Es wird immer 404 gezeigt.

    Dann stehen da so komische Sachen drin wie: .well-known/apple-app-site-association
    .well-known/assetlinks.json, lotto.html, ebaykosten.html,
     
  4. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.730
    Danke erhalten:
    10.491
    Danke vergeben:
    1.500
    Zu den komischen Sachen gab es schon mal etwas, da muss eine leere Datei angelegt werden glaube ich.

    Wenn Du URLs umbenennst, musst Du eine Weiterleitung in die .htaccess schreiben.
    Haben sich da Kategorien geändert, oder Artikel?
     
  5. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    Und dann hatte ich ja das "de" aus der Adresse genommen. Das meckert Google auch an. Die Seiten hat er 2.7. gesucht und nicht gefunden.
     
  6. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    Sowohl als auch :(
    Oh menno, da hab ich wohl ganz schön mist gemacht :(
     
  7. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    Was passiert denn, wenn ich die als korrigiert markiere? Diese Funktion gibt es ja in der Console.
     
  8. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    Ich soll in der .htaccess rumschreiben? Das geht mit Sicherheit in die Hose. Für alle 106 Fehler?
     
  9. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.730
    Danke erhalten:
    10.491
    Danke vergeben:
    1.500
    Als Korrigiert markieren nützt nichts, da sind die Zeilen nur kurz draußen.
    Du kannst sie bei Google löschen lassen, dann werden sie in den nächsten Monaten nciht gecrawlt und sind - wenn Du Glück hast - weg.

    An Hand von Google müsstest Du sehen was Du geändert hast.
    Ich habe die Umleitungen so geschrieben und bei mir funktioniert das:
    für Kategorien:
    Code:
    RewriteCond %{REQUEST_URI} alteKategorie/alteUnterkategorie
    RewriteRule ^(.*)$ https://www.domain.de/neueKategorie/neueUnterkategorie/ [L,R=301]
    für Artikel:
    Code:
    RewriteCond %{REQUEST_URI} alterArtikel
    RewriteRule ^(.*)$ https://www.domain.de/Kategorie/Unterkategorie/Artikel.html [L,R=301]
     
  10. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    Vielen Dank, liebe Barbara. Dann werde ich das mal überarbeiten. Aber was ist mit dem "de" was ja immer in meiner Adresse war? Das haben wir doch erst vor kurzem geändert. Muss ich die auch alle berücksichtigen? Das wären dann ja alle Artikel im Shop :( (ich könnt heulen) :(

    Dann hatte ich immer Groß- und Kleinschreibung in der URL und das habe ich in den letzten Tagen korrigiert und alles klein angegeben. Das wird dann beim nächsten Crawl dann erscheinen :(
     
  11. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.730
    Danke erhalten:
    10.491
    Danke vergeben:
    1.500
    Es gibt einen Code, der das für alle URLs umleitet.
    Da müsstest Du mal im Netzt suchen.
     
  12. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    Hallo Barbara, worauf bezieht sich das? auf das "de" oder auf Groß- und Kleinschreibung?

    Liebe Grüße
    Momo
     
  13. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.730
    Danke erhalten:
    10.491
    Danke vergeben:
    1.500
    Auf die Groß und Kleinschreibung
    Das fehlende de dürfte eigentlich nichts machen, das müsste der Shop selbst umleiten.
     
  14. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    Aber gehen dann die Fehlermeldungen mit de bei google von selbst raus, wenn der Shop das von selbst umleitet?
     
  15. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    Hallo,

    erstmal vielen Dank für den Code, liebe Barbara, es funktioniert wunderbar. Aber meine Htaccess füllt sich mehr und mehr. Hat das nicht am Ende Auswirkungen und es wird alles sehr lahm, wenn ich jeden einzelnen Artikel darüber umleiten lasse? Hab schon ganz viel über diese Datei im Netz gelesen die letzten beiden Tage. Aber mal ehrlich, wer versteht das? ;) Für mich ist chinesisch dagegen, klar und logisch. :(
     
  16. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    Hallo,

    irgendwie komm ich nicht so recht klar. Habe als erstes die falschen Verzeichnisse in die neuen Verzeichnisse verlinkt.
    Die Groß- und Kleinschreibung wird nicht automatisch erkannt und ich muss das immer noch extra angeben (geht wahrscheinlich einmal global, aber leider kenn ich mich damit nicht aus)
    Beispiel:

    Code:
    RewriteCond %{REQUEST_URI} /Sonstiges/Duftsaeckchen/
    RewriteRule ^(.*)$ https://www.shop-marianne-reinke.de/sonstiges/duftsaeckchen/ [L,R=301]
    
    RewriteCond %{REQUEST_URI} /Sonstiges/Lavendelsaeckchen/
    RewriteRule ^(.*)$ https://www.shop-marianne-reinke.de/sonstiges/duftsaeckchen/ [L,R=301]
    
    RewriteCond %{REQUEST_URI} Lavendelsaeckchen-LV0001.html
    RewriteRule ^(.*)$ https://www.shop-marianne-reinke.de/sonstiges/duftsaeckchen/lavendelsaeckchen-lv0001.html [L,R=301]
    
    RewriteCond %{REQUEST_URI} Sonstiges/Lavendelsaeckchen/Lavendelsaeckchen-LV0001.html
    RewriteRule ^(.*)$ https://www.shop-marianne-reinke.de/sonstiges/duftsaeckchen/lavendelsaeckchen-lv0001.html [L,R=301]
    dann wird beim Artikel nur das Verzeichnis Duftsaeckchen aufgerufen. Lösche die Verzeichnisse oben weg, dann wird der Artikel korrekt aufgerufen.

    Google bemängelt aber auch die Verzeichnisse, diese kann ich dann nicht angeben, sonst gehts nicht mehr zum Artikel.

    Bitte, bitte sagt mir doch was ich falsch mache. Sitze seit gestern um 20 Uhr davor (mit kurzer Pause zum Schlafen, war auch nicht sonderlich viel) und ich dreh noch durch. Ich verstehe das Prinzip irgendwie nicht :(

    Gruß Momo
     
  17. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    33.730
    Danke erhalten:
    10.491
    Danke vergeben:
    1.500
    Hallo Momo,

    ich habe nochmal im Netz geschaut und das hier gefunden:
    Code:
    RewriteCond %{REQUEST_URI} [A-Z]
    RewriteRule (.*) ${lc:$1} [R=301,L]
    Ich habe das nicht getestet, kann also nciht sagen ob es funktioniert.
    Der Code soll die Großbuchstaben auf klein umleiten.
     
  18. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    26. November 2015
    Beiträge:
    2.466
    Danke erhalten:
    396
    Danke vergeben:
    1.173
    Hallo Barbara,

    hatte ich gestern ausprobiert, sobald man dann auf einen Link bei Google klickt, kommt das:

    fehler.JPG