PayPal 2.4 lässt sich nicht installieren

Thema wurde von Thomas Reichert, 29. Juli 2014 erstellt.

  1. Thomas Reichert

    Thomas Reichert Erfahrener Benutzer

    Registriert seit:
    20. Februar 2014
    Beiträge:
    228
    Danke erhalten:
    7
    Danke vergeben:
    69
    Hab soeben festgestellt, dass es ein neues PayPal Update gibt. Lässt sich aber nicht installieren, stattdessen öffnet die installer.php im Editor (unter Firefox), bei allen anderen Browsern erscheint "unauthorized" im Browser. Bitte um Hilfe.
     
  2. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    22. Juni 2011
    Beiträge:
    4.286
    Danke erhalten:
    1.524
    Danke vergeben:
    107
    Zum einen ist der Installer-Aufruf beim reinen Update gar nicht nötig, zum anderen muss man als Admin im Shop eingeloggt sein, um den Installer aufrufen zu können, sonst ist man „unauthorized“.
     
  3. Thomas Reichert

    Thomas Reichert Erfahrener Benutzer

    Registriert seit:
    20. Februar 2014
    Beiträge:
    228
    Danke erhalten:
    7
    Danke vergeben:
    69
    Hallo Marco, gemäß Eurer Doku (siehe Hinweis unter Pkt. 1.1) muss aber der Installer aufgerufen werden (es ist nach Schritt 1.1 auf Schritt 1.4 zu springen), wenn man V2.0.15.4 bereits installiert hat. Ich habe V2.0.15.4 und PayPal 2.3. Und ja, ich bin als Admin eingeloggt, hab ja bisher auch alle Updates etc. installieren können. Gruß, Thomas
     
  4. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    22. Juni 2011
    Beiträge:
    4.286
    Danke erhalten:
    1.524
    Danke vergeben:
    107
    Hallo,
    wenn du schon PayPal 2.3 installiert hast, gilt aber vor allem erst mal der rote Hinweiskasten unter 1.1, nach dem es mit 1.2 weiter geht. :)
    Den paypal_installer.php brauchst du bei dem Update nicht.
     
  5. andreasgehnen

    andreasgehnen Erfahrener Benutzer

    Registriert seit:
    17. Dezember 2013
    Beiträge:
    239
    Danke erhalten:
    22
    Danke vergeben:
    65
    Hallo,


    das Update von PayPal 2.3 auf 2.4 hat bei mir einwandfrei funktioniert. Shopsoftware 2.0.15.4




    Gruß Andreas
     
  6. Manfred (zawu.eu)

    Manfred (zawu.eu) G-WARD 2012/13/14/15

    Registriert seit:
    26. April 2011
    Beiträge:
    9.098
    Danke erhalten:
    1.537
    Danke vergeben:
    907
    Ort:
    Bremen
    Wird irgendwo angezeigt, welche PP-Version installiert ist?
     
  7. Thomas Reichert

    Thomas Reichert Erfahrener Benutzer

    Registriert seit:
    20. Februar 2014
    Beiträge:
    228
    Danke erhalten:
    7
    Danke vergeben:
    69
    Wenn ich die Dateien lösche, startet mein Shop mit folgenden Fehlermeldungen:
    WARNING(2): "include_once(/var/www/vhosts/ronmclaine.com/httpdocs/shop_neu/system/overloads/Smarty/CheckoutButtonsSmarty.inc.php) [function.include-once]: failed to open stream: No such file or directory" in /var/www/vhosts/ronmclaine.com/httpdocs/shop_neu/system/core/ClassOverloadRegistry.inc.php:134 (Details)
    WARNING(2): "include_once() [function.include]: Failed opening '/var/www/vhosts/ronmclaine.com/httpdocs/shop_neu/system/overloads/Smarty/CheckoutButtonsSmarty.inc.php' for inclusion (include_path='.:/usr/share/pear')" in /var/www/vhosts/ronmclaine.com/httpdocs/shop_neu/system/core/ClassOverloadRegistry.inc.php:134 (Details)
    WARNING(2): "include_once(/var/www/vhosts/ronmclaine.com/httpdocs/shop_neu/system/overloads/Smarty/CheckoutButtonsSmarty.inc.php) [function.include-once]: failed to open stream: No such file or directory" in /var/www/vhosts/ronmclaine.com/httpdocs/shop_neu/system/core/MainFactory.inc.php:134 (Details)
    WARNING(2): "include_once() [function.include]: Failed opening '/var/www/vhosts/ronmclaine.com/httpdocs/shop_neu/system/overloads/Smarty/CheckoutButtonsSmarty.inc.php' for inclusion (include_path='.:/usr/share/pear')" in /var/www/vhosts/ronmclaine.com/httpdocs/shop_neu/system/core/MainFactory.inc.php:134 (Details)

    Fatal error: Class 'CheckoutButtonsSmarty' not found in /var/www/vhosts/ronmclaine.com/httpdocs/shop_neu/system/core/MainFactory.inc.php(53) : eval()'d code on line 1
     
  8. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    22. Juni 2011
    Beiträge:
    4.286
    Danke erhalten:
    1.524
    Danke vergeben:
    107
    Leere mal die Caches, speziell den Modul- und Seitencache.
     
  9. Michael R.

    Michael R. Erfahrener Benutzer

    Registriert seit:
    23. September 2011
    Beiträge:
    368
    Danke erhalten:
    7
    Danke vergeben:
    49
    Würde mich auch Interessieren, und wenn nicht wie finde ich die Version heraus die bei mir Installiert ist?
     
  10. Chris :-)

    Chris :-) Erfahrener Benutzer

    Registriert seit:
    8. Juli 2011
    Beiträge:
    383
    Danke erhalten:
    21
    Danke vergeben:
    38
    ...will ich auch wissen...
     
  11. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    32.635
    Danke erhalten:
    10.100
    Danke vergeben:
    1.470
    Bei dem neuen PayPal-Modul steht unter Module -> PayPal-Konfiguration unten rechts die Versionsnummer
     
  12. Manfred (zawu.eu)

    Manfred (zawu.eu) G-WARD 2012/13/14/15

    Registriert seit:
    26. April 2011
    Beiträge:
    9.098
    Danke erhalten:
    1.537
    Danke vergeben:
    907
    Ort:
    Bremen
    WOW ... ich brech ab!!! RESPEKT JUNGE FRAU!!

    <Weitere Kommentare zu der Anzeige: Zensur ON> :mad::mad::mad:
     
  13. Thomas Reichert

    Thomas Reichert Erfahrener Benutzer

    Registriert seit:
    20. Februar 2014
    Beiträge:
    228
    Danke erhalten:
    7
    Danke vergeben:
    69
    Hallo Marco, Cache geleert, keine Besserung. Im Gegenteil: Warenkorb zerschossen - PayPal-Konfiguration zerschossen (siehe screenshots). In der Artikeldetailansicht hab ich 2 PayPal-Buttons, wenn ich gemäß Anleitung die PayPalButton.js lösche, hab ich gar keinen Button. Gruß, Thomas
     

    Anhänge:

  14. Thomas Reichert

    Thomas Reichert Erfahrener Benutzer

    Registriert seit:
    20. Februar 2014
    Beiträge:
    228
    Danke erhalten:
    7
    Danke vergeben:
    69
    Hallo Marco, ich hab den kplt. Shop nochmal mit v2.0.15.4 r14570 aufgesetzt und anschließens PayPal 2.4 neu übertragen (Version 2.4_2014-05-22_1143). Jetzt ist soweit alles wieder OK ... mit Ausnahme:

    1. ich hab 2 PayPal-Buttons in der Artikeldetailansicht. Wenn ich PayPalButton.js lösche, hab ich gar keinen Button mehr.
    2. wenn ich die unter 1.2 genannten Dateien alle lösche, dann ist Warenkorb und Shop wieder zerschossen. (hab die Dateien nur umbenannt -> alles zerschossen ... Dateien wieder mit Originalnamen versehen -> Shop OK)

    Und nun sprach Zeus? Bin echt ratlos. Fehler_PayPal_Button.JPG

    PayPal funktioniert soweit.
     
  15. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.400
    Danke erhalten:
    6.631
    Danke vergeben:
    2.007
    Hi Thomas,

    der zweite Button auf der Artikeldetailseite wird von der /templates/EyeCandy/usermod/javascript/ProductInfo/PayPalButton.js hinzugefügt, die muss weg. Wenn ich jetzt auf deinen Shop schaue, sieht alles ok aus. Kann man das irgendwo in dem Zustand sehen ?
     
  16. KnarfR

    KnarfR Erfahrener Benutzer

    Registriert seit:
    15. März 2013
    Beiträge:
    239
    Danke erhalten:
    44
    Danke vergeben:
    101
    Vorab, installiert war vor dem Update die Shop Version 2.0.15.4 und PayPal 2.3

    Ich habe gerade das PayPal Update auch durchgeführt, muss aber gestehen, dass ich wie Thomas auch den Installer ausgeführt habe.

    Lösche ich, wie in der Anleitung beschrieben, die Datei
    "/system/overloads/Smarty/CheckoutButtonsSmarty.inc.php"
    bekomme ich denselben Fatal Error (Shop nicht mehr nutzbar) wie Thomas.

    Kopiere ich die Datei zurück, ist wieder alles in Ordnung.
    Auch ein leeren des Caches unter Tools hilft nichts.

    Ist das jetzt ein ernstzunehmendes Problem?
    Ich kann in der Kürze kein Problem feststellen.

    MfG. Moni

     
  17. Thomas Reichert

    Thomas Reichert Erfahrener Benutzer

    Registriert seit:
    20. Februar 2014
    Beiträge:
    228
    Danke erhalten:
    7
    Danke vergeben:
    69
    2 PayPal-Button in Artikeldetails

    Da warst Du auf einem falschen Shop ;). Ich hab den betreffenden Shop grade eben erst freigeschaltet: www.ronmclaine.com/shop_neu ... ist noch nicht aktiv. Hier siehst Du in den Artikeldetails, dass es 2 PP-Buttons gibt. Wird wie gefordert die PayPalButton.js gelöscht, erscheinen gar kein Button mehr.
     
  18. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    6. November 2013
    Beiträge:
    372
    Danke erhalten:
    14
    Danke vergeben:
    99
    @andreasgehnen

    Bitte schaue mal ob bei Dir wenn Du auf eine Kundenbestellung mit PayPal klickst der Bereich Rückzahlung 2x auftaucht. 1x mit Daten und dann raunter noch einmal, jedoch nur die Buttons und keine Daten.

    Vielen Dank :)
     
  19. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    6. November 2013
    Beiträge:
    372
    Danke erhalten:
    14
    Danke vergeben:
    99
    Moni, das gleiche Problem habe ich auch. Aber laut Gambio Support ist alles OK :) Wie immer ... :) Ist es aber nicht, leider ... :-(
     
  20. andreasgehnen

    andreasgehnen Erfahrener Benutzer

    Registriert seit:
    17. Dezember 2013
    Beiträge:
    239
    Danke erhalten:
    22
    Danke vergeben:
    65
    @meicker

    Hallo Marc,

    der Button ist nur 1x zu sehen.


    Gruß Andreas