Service Pack v3.3.2.0 erschienen

Thema wurde von Michael (Gambio), 6. Januar 2017 erstellt.

  1. Michael (Gambio)

    Michael (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    140
    Danke erhalten:
    217
    Danke vergeben:
    25
    #1 Michael (Gambio), 6. Januar 2017
    Zuletzt bearbeitet: 6. Januar 2017
    Hallo zusammen,

    ab jetzt steht im Downloadbereich des Kundenportals das Service Pack v3.3.2.0 und die dazugehörige Vollversion v3.3.2.0 für euch bereit.

    Das Service Pack v3.3.2.0 ist ausschließlich für die Shopversionen v3.3.1.0, v3.3.1.1 und v3.3.1.2 vorgesehen.

    Neuerungen und Änderungen in der Version 3.3.2.0 beta1
    Neuerungen und Änderungen in der Version 3.3.2.0
     
  2. Anonymous

    Anonymous Beta-Held

    Registriert seit:
    18. Dezember 2014
    Beiträge:
    1.571
    Danke erhalten:
    461
    Danke vergeben:
    466
    @Gambio,

    Update von 3.3.2.0 BETA1 auf 3.3.2.0 im Testshop (Link nur für registrierte Nutzer sichtbar.) fehlerfrei durchgelaufen, keine Probleme entdeckt. Testbestellung OK. ;):cool::D
     
  3. hartwigbusse

    hartwigbusse Erfahrener Benutzer

    Registriert seit:
    10. Dezember 2014
    Beiträge:
    544
    Danke erhalten:
    99
    Danke vergeben:
    220
    Alles Ok :)
     
  4. Anonymous

    Anonymous Beta-Held

    Registriert seit:
    6. September 2011
    Beiträge:
    793
    Danke erhalten:
    180
    Danke vergeben:
    220
    Update im Liveshop von v3.3.2.0 (BETA1) auf 3.3.2.0 erfolgreich! :)
    Testbestellung auch ok! :)
    Soweit nichts Negatives festgestellt!;)
     
  5. bt012ss

    bt012ss Erfahrener Benutzer

    Registriert seit:
    18. März 2012
    Beiträge:
    984
    Danke erhalten:
    276
    Danke vergeben:
    156
    Update von 3.3.2.0 (BETA1) auf 3.3.2.0 und kein Zugriff mehr auf den Shop.

    Code:
    FATAL ERROR(1): "Class 'ApplicationBottomExtenderComponent' not found"Information:
    <br />
    <b>Fatal error</b>:  Class 'ApplicationBottomExtenderComponent' not found in <b>/shop/system/core/ClassOverloadRegistry.inc.php(207) : eval()'d code</b> on line <b>1</b><br />
    
    Ein erneutes hochladen der Dateien bringt keinen Erfolg.
    Eine Lösung dafür?
     
  6. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    8.468
    Danke erhalten:
    2.930
    Danke vergeben:
    926
    Ich hab kurz in deine Daten bei uns geschaut: Stimmt es dass wir den Shop nicht ansehen könnten? Sonst hätte ich gern ein Ticket. Gefühlmässig stimmt da was in system/extender oder system/core nicht.
     
  7. Dennis (Print-Weilburg.de)

    Dennis (Print-Weilburg.de) G-WARD 2013/14/15/16

    Registriert seit:
    22. September 2011
    Beiträge:
    24.893
    Danke erhalten:
    4.732
    Danke vergeben:
    893
    Beruf:
    Mann für alles :)
    Ort:
    Weilburg
    läuft live bei uns nun. Danke. Sehe so auf Anhieb nix was falsch läuft.

    ps. Fürs nächste Update bitte
    1. Bilder Reihenfolge im Admin änderbar machen bei Artikeln.
    2. Artikelbilder Sitemap für Google Bildersuche
    3. weiter und zurück Button in Bestell Bearbeitung damit man nicht immer zur Übersicht muss
    4. reCaptcha von Google mit "Ich bin kein Roboter" statt den unleserlichen Buchstaben
     
  8. bt012ss

    bt012ss Erfahrener Benutzer

    Registriert seit:
    18. März 2012
    Beiträge:
    984
    Danke erhalten:
    276
    Danke vergeben:
    156
    Die Daten habt ihr alle, ich bin gerade unterwegs in die Schweiz und kann nix mehr machen.
     
  9. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    4.656
    Danke erhalten:
    1.977
    Danke vergeben:
    549
    Es könnte sich auch um einen Bug im neuen Caching-System der MainFactory handeln. Darf ich für diesen Fall mit den FTP-Daten, die du im Portal hinterlegt hast, auf deinen Server zugreifen und das Problem analysieren?
     
  10. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    8.468
    Danke erhalten:
    2.930
    Danke vergeben:
    926
    Soweit gut :)

    Das sind alles Änderungen die keine Fehlerbehebungen sind, damit sind die als neue Features zu werten, nicht als Bug, was die Chancen das zwischendrin zu machen ziemlich schmal hält. Das sind tendenziell Sachen für ein Featureupdate wie 3.5.1.0 oder 3.7.1.0.

    By the way:
    Du missbrauchst diesen Thread als Ort für gesammelte Featurewünsche. Weil das nicht gilt, hier gehts um was anderes, und du lieber Dennis als Forenleuchte das wissen müsstest und trotzdem versuchst, erzieh ich dich jetzt mal etwas. Ich trag das nicht ein, bis du das an einem richtigeren Ort wünscht :)
     
  11. Dennis (Print-Weilburg.de)

    Dennis (Print-Weilburg.de) G-WARD 2013/14/15/16

    Registriert seit:
    22. September 2011
    Beiträge:
    24.893
    Danke erhalten:
    4.732
    Danke vergeben:
    893
    Beruf:
    Mann für alles :)
    Ort:
    Weilburg
  12. bt012ss

    bt012ss Erfahrener Benutzer

    Registriert seit:
    18. März 2012
    Beiträge:
    984
    Danke erhalten:
    276
    Danke vergeben:
    156
    Logisch.
     
  13. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    4.656
    Danke erhalten:
    1.977
    Danke vergeben:
    549
    Du hattest Dateien unvollständig hochgeladen. Im system/extender Ordner waren drei Dateien ohne Inhalt. Es könnten noch mehr Dateien betroffen sein. Der Shop ist jedenfalls wieder erreichbar.
     
  14. bt012ss

    bt012ss Erfahrener Benutzer

    Registriert seit:
    18. März 2012
    Beiträge:
    984
    Danke erhalten:
    276
    Danke vergeben:
    156
    Danke :)
    Mehr als zweimal das komplette Paket hochladen bleibt mir nicht.
    Wenn ich zu Hause bin guck ich mal in das Download Paket.
     
  15. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    22. September 2011
    Beiträge:
    355
    Danke erhalten:
    18
    Danke vergeben:
    65
    @Gambio
    Update auf 3.3.2.0 erfolgreich duchgeführt. Im Prinzip funktioniert alles.
    Ein Problem gibt es bei mir im Liveshop, beim Artikelexport z.B. für Googleshopping werden nur noch Artikel mit Attributen und Eigenschaften berücksichtigt alle anderen Artikel nicht. Die Häkchen bei den Kategorien sind alle gesetzt.
    Alles was mir dazu einfällt habe ich überprüft.
    Bitte mal nachsehen.
     
  16. humpfle

    humpfle Erfahrener Benutzer

    Registriert seit:
    14. Juli 2011
    Beiträge:
    783
    Danke erhalten:
    59
    Danke vergeben:
    86
    Kann ich bestätigen. Für uns leider ein riesiges Problem. Bitte um schnelle Fehlerbehebung
     
  17. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    8.468
    Danke erhalten:
    2.930
    Danke vergeben:
    926
    Ihr soltet dazu bitte ein Ticket einwerfen, das muss man sich im Shop ansehen.
     
  18. kalle_b

    kalle_b Erfahrener Benutzer

    Registriert seit:
    22. Mai 2015
    Beiträge:
    155
    Danke erhalten:
    4
    Danke vergeben:
    55
    Update von 3.3.1.0 auf 3.3.2.0 im Testshop durchgeführt. Nachfolgender Fehler, wenn ich auf Kunden>E-Mails zugreife:
    @Gambio: hat jemand von Euch eine Idee hierzu?

    Fatal error
    : Uncaught exception 'InvalidArgumentException' with message 'Provided uploads directory path does not exist in the server: /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/uploads' in /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/GXMainComponents/Services/System/Email/AttachmentsHandler.inc.php:52 Stack trace: #0 /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/system/core/MainFactory.inc.php(517) : eval()'d code(1): AttachmentsHandler->__construct('/homepages/10/d...') #1 /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/system/core/MainFactory.inc.php(517): eval() #2 /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/system/core/MainFactory.inc.php(300): MainFactory::create_object('AttachmentsHand...', Array) #3 /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/GXMainComponents/Services/System/Email/EmailFactory.inc.php(338): MainFactory::create('AttachmentsHand...', '/homepages/10/d...') #4 /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/GXMainComponents/Services/System/Email/EmailFactory.inc.php(275): EmailFactory->crea in /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/GXMainComponents/Services/System/Email/AttachmentsHandler.inc.php on line 52
    FATAL ERROR(1): "Uncaught exception 'InvalidArgumentException' with message 'Provided uploads directory path does not exist in the server: /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/uploads' in /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/GXMainComponents/Services/System/Email/AttachmentsHandler.inc.php:52
    Stack trace:
    #0 /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/system/core/MainFactory.inc.php(517) : eval()'d code(1): AttachmentsHandler->__construct('/homepages/10/d...')
    #1 /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/system/core/MainFactory.inc.php(517): eval()
    #2 /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/system/core/MainFactory.inc.php(300): MainFactory::create_object('AttachmentsHand...', Array)
    #3 /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/GXMainComponents/Services/System/Email/EmailFactory.inc.php(338): MainFactory::create('AttachmentsHand...', '/homepages/10/d...')
    #4 /homepages/10/d406104450/htdocs/r-b_3.3.3.1_v1/GXMainComponents/Services/System/Email/EmailFactory.inc.php(275): EmailFactory->crea"
     
  19. humpfle

    humpfle Erfahrener Benutzer

    Registriert seit:
    14. Juli 2011
    Beiträge:
    783
    Danke erhalten:
    59
    Danke vergeben:
    86
    Ich bin mir ziemlich sicher, dass alle das Problem mit der Version 3.3.2.0 haben, sobald bei den jeweiligen Artikelexport Einstellungen die Checkbox "Eigenschaften" selektiert ist.

    Als Workaround kann die Checkbox deselektiert werden damit zumindest der Großteil der Produkte wieder exportiert werden kann.

    Bei Gelegenheit erstelle ich ein Ticket.
     
  20. Dennis (Print-Weilburg.de)

    Dennis (Print-Weilburg.de) G-WARD 2013/14/15/16

    Registriert seit:
    22. September 2011
    Beiträge:
    24.893
    Danke erhalten:
    4.732
    Danke vergeben:
    893
    Beruf:
    Mann für alles :)
    Ort:
    Weilburg
    Ja kann ich bestätigen vor dem Update waren es 11.777 Export Artikel
    Nach dem Update nur noch 7.987
    Da sind also einige ohne Eigenschaften weggefallen.