Sprachumstellung ohne Dropdown

Thema wurde von barbara, 24. Januar 2018 erstellt.

  1. Christian Mueller

    Christian Mueller Beta-Held

    Registriert seit:
    4. Juli 2011
    Beiträge:
    3.480
    Danke erhalten:
    771
    Danke vergeben:
    259
    Template
     
  2. FRAGO

    FRAGO Erfahrener Benutzer

    Registriert seit:
    5. Dezember 2019
    Beiträge:
    925
    Danke erhalten:
    285
    Danke vergeben:
    132
    @Sergej (Gambio)
    tut es nur bei mir nicht oder kann es sein das es mit v4.2.1.0 MALIBU nicht funktioniert...

    DL Paket aus Post #134 und die Änderung aus Post #137.
     
  3. Christian Mueller

    Christian Mueller Beta-Held

    Registriert seit:
    4. Juli 2011
    Beiträge:
    3.480
    Danke erhalten:
    771
    Danke vergeben:
    259
    Das ist eine Lösung für Honeygrid. Die wird in Malibu nicht funktionieren.
     
  4. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    18. Juli 2019
    Beiträge:
    386
    Danke erhalten:
    61
    Danke vergeben:
    22
    Ich habe das testweise mal versucht einzubauen, da meine Kunden immer wieder meckern dass sie die Länderauswahl nicht finden, ist ja auch winzig klein. Ich hätte auch gerne eine Fahne, das fällt wenigstens auf.

    Ich habe Honeygrid Theme, Version 4.4.0.3
    Nach Installation erhalte ich mehrfach

    CSS compile error 'is_file(): open_basedir restriction in effect. File(../../../Styles/icons.scss) is not within the allowed paths: (/var/........./:/tmp/)

    CSS compile error 'is_file(): open_basedir restriction in effect. File(../../../Styles/icons) is not within the allowed paths: (/var/........./:/tmp/)

    CSS compile error 'is_file(): open_basedir restriction in effect. File(../../../Styles/_icons.scss) is not within the allowed paths: (/var/........./:/tmp/)

    CSS compile error 'is_file(): open_basedir restriction in effect. File(../../../Styles/_icons) is not within the allowed paths: (/var/........./:/tmp/)

    Was könnte ich da tun?

    Ich habe gesehen dass da in main.scss folgendes steht:
    @import "../../../Styles/icons";

    Das führt wohl ins leere?
     
  5. Sergej (Gambio)

    Sergej (Gambio) Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    1. August 2016
    Beiträge:
    288
    Danke erhalten:
    152
    Danke vergeben:
    53
    Neues Paket sollte ab 4.6 wieder laufen...

    Anpassung bereits vorhanden?
    Den Ordner "HBoxLanguage" unter "GXModules/GambioCE" vom Server löschen.
    Den Ordner "HBoxLanguage" aus dem neuen Paket in den Ordner "GXModules/GambioCE" hochladen.
    Caches leeren.

    Anpassung noch nicht vorhanden?
    Den Ordner "GambioCE" aus dem neuen Paket in den Ordner "GXModules" hochladen
    Caches leeren.

    Die Anpassung ist nur für Themes ausgelegt ;)
     

    Anhänge:

  6. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    18. Juli 2019
    Beiträge:
    386
    Danke erhalten:
    61
    Danke vergeben:
    22
    Das läuft also nur ab 4.6 richtig?
     
  7. FRAGO

    FRAGO Erfahrener Benutzer

    Registriert seit:
    5. Dezember 2019
    Beiträge:
    925
    Danke erhalten:
    285
    Danke vergeben:
    132
    würde ich so verstehen und auch nur im Honeygrid.
     
  8. Sergej (Gambio)

    Sergej (Gambio) Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    1. August 2016
    Beiträge:
    288
    Danke erhalten:
    152
    Danke vergeben:
    53
    Es wurde unter GX4.6 entwickelt. Inwiefern es mit älteren Versionen kompatibel ist wurde nicht gegen geprüft.
    Gerne ausprobieren und der Community mitteilen, ob es auch in deiner Version funktioniert :)

    Nein. Es sollte unter allen Theme-basierten Vorlagen funktionieren, die "Gambiokonform" angelegt wurden. Abwärtskompatibilität s.o.
     
  9. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    13. Juni 2018
    Beiträge:
    147
    Danke erhalten:
    75
    Danke vergeben:
    85
    #149 Anonymous, 6. August 2022
    Zuletzt bearbeitet: 7. August 2022
    Es läuft unter 4.4, aber mobil wird jetzt nichts mehr angezeigt, es gibt keine Möglichkeit der Sprachumstellung, weder in 4.4 noch 4.6. Nach der Deinstallation im live Shop ist die Sprachumstellung Mobil wieder zu sehen.
    Das ist natürlich echt doof, lässt sich da etwas machen?
    Sonst finde ich es echt gut, ich hab die Bilder ausgetauscht, die Icons aus dem Shop Verzeichnis sind sehr unscharf, sieht wie gewollt und nicht gekonnt aus.
    Solltet Ihr änder, nicht professionell! Kann man besser machen.
    Auf dem 2. Bild mal meine eigene Variante ohne diese Erweiterung, ja ich weiß, die beiden Icons sind nicht mittig, werde ich noch anpassen.
    Das DE versuche ich noch wegzubekommen, falls jemand eine Idee hat, wäre ich sehr dankbar ;-) Diese DE war nach der Installation und Deinstallation der Erweiterung da, vorher definitiv nicht. Auch doof ;-)
     

    Anhänge:

    • icon.png
      icon.png
      Dateigröße:
      10,2 KB
      Aufrufe:
      13
    • la2.png
      la2.png
      Dateigröße:
      10,9 KB
      Aufrufe:
      13
  10. Sergej (Gambio)

    Sergej (Gambio) Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    1. August 2016
    Beiträge:
    288
    Danke erhalten:
    152
    Danke vergeben:
    53
    Das neue Paket sollte nun auch in der mobilen Ansicht den Wechsel der Sprache ohne Dropdown ermöglichen.

    Anpassung bereits vorhanden?
    Den Ordner "HBoxLanguage" unter "GXModules/GambioCE" vom Server löschen.
    Den Ordner "HBoxLanguage" aus dem neuen Paket in den Ordner "GXModules/GambioCE" hochladen.
    Caches leeren.

    Anpassung noch nicht vorhanden?
    Den Ordner "GambioCE" aus dem neuen Paket in den Ordner "GXModules" hochladen
    Caches leeren.

    Die Anpassung ist nur für Themes ausgelegt ;)
     

    Anhänge: