Timeout bei Artikelmodifikation

Thema wurde von HolgerNils (xycons.de), 30. Juli 2012 erstellt.

  1. HolgerNils (xycons.de)

    HolgerNils (xycons.de) G-WARD 2013/2014

    Registriert seit:
    29. Oktober 2011
    Beiträge:
    1.957
    Danke erhalten:
    448
    Danke vergeben:
    367
    Liebes Gambio-Team,
    könnt Ihr bitte bei nächster Gelegenheit diesen Sch....ss-Timeout abschalten, wenn man Artikel editiert !?
    Ich habe heute zum x-ten Male lange Artikeltexte verloren, weil während des Editierens der Timeout abgelaufen war und anstatt zu "aktualisieren" oder zu "speichern" auf die Anmeldeseite gesprungen wurde - natürlich unter Verlust sämtlicher Texte und Änderungen. Auch über "zurück" nix zu machen.

    Wäre sehr freundlich!
     
  2. Petra

    Petra G-WARD 2013/14/15

    Registriert seit:
    27. August 2011
    Beiträge:
    6.998
    Danke erhalten:
    1.211
    Danke vergeben:
    227
    Du glaubst nicht, wie mich das schon geärgert hat. Inzwischen kopiere ich die Texte in die Zwischenablage, wenn es mal länger dauert. Das ist definitiv kein Zustand, denn alles andere ist dann sowieso weg. Und was ganz hässlich ist, dass er teils Artikel ohne Überschrift anlegt und dann probier mal drauf zu kommen, wenn die nicht gerade ganz oben stehen.
     
  3. Dennis (Print-Weilburg.de)

    Dennis (Print-Weilburg.de) G-WARD 2013/14/15/16

    Registriert seit:
    22. September 2011
    Beiträge:
    30.280
    Danke erhalten:
    5.877
    Danke vergeben:
    1.051
    Beruf:
    Mann für alles :)
    Ort:
    Weilburg
    ich hab dafür immer ein Fenster offen in dem ich den Shop dann neu lade bevor ich artikel abschicke. also wenn ich mal wieder von den lästigen Kunden bei der arbeit unterbrochen worden bin :)
    Wenn du Opera nutzt oder sonst einAdOn hast, kannst da auch ein fenster immer alle Minute autom. neu laden lassen, dann passiert dir da auch nx.

    Aber ja, der Timeout nervt.
     
  4. barbara

    barbara G-WARD 2014/15/16

    Registriert seit:
    14. August 2011
    Beiträge:
    28.148
    Danke erhalten:
    8.425
    Danke vergeben:
    1.291
    Da gab es mal einen super Tipp von Manfred:
    in der /admin/start.php steht am Anfang:
    Code:
    <html <?php echo HTML_PARAMS; ?>>
    	<head>
    darunter folgendes Einfügen:
    Code:
    <meta http-equiv="refresh" content="60">
    Wenn ich jetzt die Admin Startseite in einem Fenster offen lasse, kann ich ganz in Ruhe in anderen Bereichen rumwuseln, ohne rauszufliegen
     
  5. Dennis (Print-Weilburg.de)

    Dennis (Print-Weilburg.de) G-WARD 2013/14/15/16

    Registriert seit:
    22. September 2011
    Beiträge:
    30.280
    Danke erhalten:
    5.877
    Danke vergeben:
    1.051
    Beruf:
    Mann für alles :)
    Ort:
    Weilburg
    ja auch eine möglichkeit den reload der seite zu automatisieren.
     
  6. MadMatt

    MadMatt Mitglied

    Registriert seit:
    17. August 2011
    Beiträge:
    22
    Danke erhalten:
    0
    Danke vergeben:
    5
    Danke Danke
     
  7. wurmi023

    wurmi023 Erfahrener Benutzer

    Registriert seit:
    24. August 2012
    Beiträge:
    419
    Danke erhalten:
    30
    Danke vergeben:
    46
    In der neuesten Version von Gambio ist ja der Reload drinnen, ABER mit reloadet der bissal zu oft.
    Kann man diese Zeit etwas verändern...? So dass er nur alle 5 Minuten neu lädt, denn 30 sek sind übertrieben.
     
  8. Manfred (zawu.eu)

    Manfred (zawu.eu) G-WARD 2012/13/14/15

    Registriert seit:
    26. April 2011
    Beiträge:
    9.035
    Danke erhalten:
    1.499
    Danke vergeben:
    871
    Ort:
    Bremen
    Siehe: (Link nur für registrierte Nutzer sichtbar.)
     
  9. Simer

    Simer Erfahrener Benutzer

    Registriert seit:
    30. Juli 2012
    Beiträge:
    281
    Danke erhalten:
    7
    Danke vergeben:
    55
    Wir habe aktuell genau das Problem, dass Kunden ohne eingeloggt zu sein, nach kurzer Zeit rausfliegen und der Warenkorb geleert wird. Zu schnell! Nach unserem Hoster gehts in der .htaccess zu ändern, wenn man die lifetime ändert. Wo und wie genau, kann da jemand helfen. Haben aktuell die 3.15.3.1
     
  10. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    15.923
    Danke erhalten:
    5.941
    Danke vergeben:
    1.819
    Das ist hosterspezifisch, manchmal klappt das:

    Code:
    php_value session.gc_maxlifetime 6000
    php_value session.gc_divisor 1
     
  11. Simer

    Simer Erfahrener Benutzer

    Registriert seit:
    30. Juli 2012
    Beiträge:
    281
    Danke erhalten:
    7
    Danke vergeben:
    55
    OK, an welcher Stelle der .htaccess?
     
  12. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    15.923
    Danke erhalten:
    5.941
    Danke vergeben:
    1.819
    egal.
     
  13. Simer

    Simer Erfahrener Benutzer

    Registriert seit:
    30. Juli 2012
    Beiträge:
    281
    Danke erhalten:
    7
    Danke vergeben:
    55
    Super, danke
     
  14. Simer

    Simer Erfahrener Benutzer

    Registriert seit:
    30. Juli 2012
    Beiträge:
    281
    Danke erhalten:
    7
    Danke vergeben:
    55
    Hallo,

    leider klappt es doch nicht, wie erhofft. Wir selber fliegen nach ein paar Minuten raus und den Kunden (ohne eingeloggt zu sein) wird der Warenkorb gelöscht. Die .httaccess-Lösung geht wohl nur, wenn der Hoster dies serverseitig zulässt.

    # -----------------------------------------------------------------------------
    # Lifetime Anpassung
    # -----------------------------------------------------------------------------
    php_value session.cookie_lifetime 10000
    php_value session.gc_maxlifetime 10000
    php_value session.gc_divisor 1
    # -----------------------------------------------------------------------------
    # Disable ETags for Performance
    # -----------

    Gibt´s da eine andere Lösung, die sicher und stetig den Kunden eine Session und den Warenkorb-Inhalt ermöglicht? Geht er vom Rechner weg, kommt nach 30 Min wieder, ist alles weg - und der Kunde dann auch aus dem Shop. Das kann so nicht sein.
     
  15. barbara

    barbara G-WARD 2014/15/16

    Registriert seit:
    14. August 2011
    Beiträge:
    28.148
    Danke erhalten:
    8.425
    Danke vergeben:
    1.291
    Wie lange soll eine Sesseion ohne Anmeldung und ohne Aktivität des Kunden denn halten?
    Wie viele Kunden unterbrechen den Einkauf wirklich so lange und würden ihn dann weiterführen?

    Für Admins kannst Du die dauer unter Shop Einstellungen -> System Einstellungen -> Sessions festlegen.
     
  16. Simer

    Simer Erfahrener Benutzer

    Registriert seit:
    30. Juli 2012
    Beiträge:
    281
    Danke erhalten:
    7
    Danke vergeben:
    55
    Hey,

    die admins haben wir auf 6000 gestellt, alle anderen Angaben darüber weiter auf "schwarz" statt "grün" gelassen. Aber irgendwie fliegen wir trotzdem nach 15 Min - auch als Admin - raus, wenn wir nicht aktiv sind.

    Den Kunden sollte man ruhih Zeit genug geben, finden wir. Ne Stunde oder zwei, das kommt vor bei uns, dass sie verschwinden, woanders stöbern und dann weitermachen (wollen), was aber nicht mehr geht - Session zu Ende, Warenkorb leer. Wieviele, das kann man nur erahnen. Beschwert haben sich schon einge bei uns dazu, gerade wenn sie kein Konto haben, weil der Merkzettel dann auch nicht funct.
     
  17. barbara

    barbara G-WARD 2014/15/16

    Registriert seit:
    14. August 2011
    Beiträge:
    28.148
    Danke erhalten:
    8.425
    Danke vergeben:
    1.291
    6000 min = 100 Stunden - Ihr habt aber lange Arbeitszeiten :D

    Wenn ich gerade nichts im Admin erledige, stelle ich die Admin-Startseite ein. da bleibe ich ewig angemeldet (und bei mir stehen nur 240min) aber auch wenn ich das vergesse, bleibe ich lange angemeldet.

    Wenn Dein Hoster angibt, dass das in der .htaccess geht, dann müsste er Dir doch auch sagen können, wie man das macht.
    Also welchen Code Du da eingeben musst, damit das geht.
     
  18. Simer

    Simer Erfahrener Benutzer

    Registriert seit:
    30. Juli 2012
    Beiträge:
    281
    Danke erhalten:
    7
    Danke vergeben:
    55
    Habe die Allinkl angeschrieben, warten auf Antwort.