gelöst Welche GX Version ist zu welcher PHP Version kompatibel?

Thema wurde von sirtet, 3. März 2021 erstellt.

  1. sirtet

    sirtet Erfahrener Benutzer

    Registriert seit:
    4. Juli 2012
    Beiträge:
    1.059
    Danke erhalten:
    87
    Danke vergeben:
    80
    #1 sirtet, 3. März 2021
    Zuletzt bearbeitet: 24. November 2021
    Genauer gesagt, was ist die jeweils höchste unterstützte PHP Version der verschiedenen GX Versionen?

    Ich würde meinen Shop gerne updaten von 3.9 auf ... irgendwas neueres, aus verschiedenen Gründen.

    Vor allem muss ich dringend eine möglichst neue PHP Version einsetzen können, mein Hoster schneidet alte Zöpfe ab.
    Momentan kann ich wegen WAWI Kompatibilität maximal auf 4.0 wechseln, aber generell würde mich auch für neuere Versionen interessieren, was die maximal unterstützte PHP-Version ist.
    Und: Was unterstützt 3.9?

    EDIT:
    Lösung gemäss Wilken, Post #12:
    https://tracker.gambio-server.net/projects/gxdoc/wiki/Unterstützte_PHP-Versionen
     
  2. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    2. Mai 2012
    Beiträge:
    522
    Danke erhalten:
    222
    Danke vergeben:
    118
  3. KlausK

    KlausK Erfahrener Benutzer

    Registriert seit:
    7. Oktober 2012
    Beiträge:
    527
    Danke erhalten:
    105
    Danke vergeben:
    20
    GX 3.9 kann nur bis PHP 7.2.x. Diese PHP-Version ist aber auch schon End of life.
    Wenn dein Hoster radikal vorgeht, wird er nur noch PHP 7.3.x und höher zulassen.
    Damit kannst du dann auf GX 4.0.x updaten. Das funktioniert einwandfrei.

    Aber denk dran: Auch PHP 7.3.x befindet sich bereits in der Endphase und erreicht die Eol am 06.12.2021

    @Stefanie (Gambio)
    Wird PHP 8 bereits vollständig unterstützt? Oder ab wann?
     
  4. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    18.601
    Danke erhalten:
    7.223
    Danke vergeben:
    2.190
    Nein, PHP 8 läuft noch nicht. Der nötige Umbau ist gross, PHP8 verändert viel. GX4.7 ist eine lose Schätzung, vorher definitiv nicht.
     
  5. sirtet

    sirtet Erfahrener Benutzer

    Registriert seit:
    4. Juli 2012
    Beiträge:
    1.059
    Danke erhalten:
    87
    Danke vergeben:
    80
    3.9 sollte also mit 7.2 klarkommen laut dem oben verlinkten Dokument.
    Ich bekomme aber an diversen Stellen Warnings,
    Code:
    Warning: sizeof(): Parameter must be an array or an object that implements Countable
    Schaut etwas unschön aus, blöder ist etwa beim Checkout nur eine Leere Seite mit
    Code:
    WARNING(2): "Illegal string offset 'url'"
    WARNING(2): "Illegal string offset 'url'"
    WARNING(2): "Illegal string offset 'url'"
    WARNING(2): "Illegal string offset 'url'"
    WARNING(2): "Illegal string offset 'url'"
    WARNING(2): "Illegal string offset 'url'"
    WARNING(2): "Illegal string offset 'url'"
    WARNING(2): "Illegal string offset 'url'"
    WARNING(2): "Illegal string offset 'url'"
    WARNING(2): "Cannot modify header information - headers already sent by (output started at /home/toronetc/public_html/paddlershop.ch/catalog/gm/classes/ErrorHandler.php:419)"
    Obwohl die Bestellung ankommt.

    7.1 kann ich noch eine Weile Nutzen vom Hoster aus, da habe ich keine Fehler.
     
  6. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    19. Juni 2012
    Beiträge:
    4.794
    Danke erhalten:
    1.100
    Danke vergeben:
    928
    Der Link ist tot? Man kann auch keinen aktuellen Link raten. Warum macht ihr das immer so, dass tote Links entstehen? Stabile URLs schaffen? Übersichtsseiten für die verfügbaren Versionen schaffen? Weiterleitungen einrichten?
     
  7. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    34.906
    Danke erhalten:
    10.993
    Danke vergeben:
    1.565
    versuche es mal hiermit:
    (Link nur für registrierte Nutzer sichtbar.)
    geht auch mit 4.5:
    (Link nur für registrierte Nutzer sichtbar.)

    Allerdings findet man das nciht unter "Tutorials GX4", wie ich vermutet hätte, sondern unter "Tutorials GX3"
     
  8. Anonymous

    Anonymous Erfahrener Benutzer
    Mitarbeiter

    Registriert seit:
    2. Mai 2012
    Beiträge:
    522
    Danke erhalten:
    222
    Danke vergeben:
    118
    Oder man geht diesen Weg:

    1. https://developers.gambio.de/
    2. rechts oben Shopversion auswählen
    3. Dann "Tutorials GX3" anklicken
    4. rechts im Menü "Unterstützte PHP-Versionen" auswählen
     
  9. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    34.906
    Danke erhalten:
    10.993
    Danke vergeben:
    1.565
    Vielleicht sollten die "Kacheln umbenannt werden.
    Ein User mit einem GX4.x sucht nicht unter GX3.
    Vielleicht in "Tutorial Allgemein GX3 / GX4" und "Tutorial GX4 Entwickler"
     
  10. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    19. Juni 2012
    Beiträge:
    4.794
    Danke erhalten:
    1.100
    Danke vergeben:
    928
    Oder nicht "Tutorial"... Ist kein Tutorial.
     
  11. sirtet

    sirtet Erfahrener Benutzer

    Registriert seit:
    4. Juli 2012
    Beiträge:
    1.059
    Danke erhalten:
    87
    Danke vergeben:
    80
    Also @GAMBIO, wie ist's denn nun mit den PHP Versionen?
    Es gibt zwar eine Tabelle, aber die ist ja nur halbvoll...
    https://developers.gambio.de/tutorials.html?v=4.5.1.0_beta1&p=unterstützte-php-versionen
    upload_2021-11-24_17-15-34.png

    1. Wie ist die Spalte Anmerkungen zu verstehen? |7.1.x heisst was?
    2. Was ist mit PHP Max. ? habt ihr da keine Ahnung, oder was bedeutet da nichts?
    Konkret für mich würd ich gerne wissen was 4.0.x und 3.9.x maximal aushalten.
    3.9 hab ich selbst, und da bekomme ich bei 7.2 jetzt schon Fehler...
     
  12. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    18.601
    Danke erhalten:
    7.223
    Danke vergeben:
    2.190
  13. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    15. September 2011
    Beiträge:
    122
    Danke erhalten:
    14
    Danke vergeben:
    46
    Hallo Wilken,

    ich habe noch einen weiteren Shop mit der Version 4.0.0.0
    Estugo möchte php 7.3... abschalten.
    Gibt es Probleme, wenn ich auf php 7.4... umstelle?
     
  14. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    18.601
    Danke erhalten:
    7.223
    Danke vergeben:
    2.190
    Kurze Antwort: Ja.

    Es gibt ein paar bekannte Probleme, wie Fehler aus der PDF Erzeugung, die man mit neuerem PDF Creator lösen kann, da waren aber noch ein paar Sachen die ich aus dem Kopf so nicht mehr alle weiss plus Potenzial für eine Dunkelziffer. Wir haben das schlussendlich nie echt systematisch für die Frage genau erfasst, weil nie Ziel war dass das ohne Update geht.
     
  15. Don Alfredo

    Don Alfredo Erfahrener Benutzer

    Registriert seit:
    27. Januar 2012
    Beiträge:
    250
    Danke erhalten:
    5
    Danke vergeben:
    108
    Die PHP Version 7.4 wird am 14.11.2022 deaktiviert. Alle Domains/Verzeichnisse, die zu diesem Zeitpunkt auf PHP 7.4 im KIS eingestellt sind, werden automatisch auf die PHP Version 8.1 umgestellt.
    Wenn ich das richtig verstanden habe gibt es dafür noch keine Version.
     
  16. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    30. Oktober 2015
    Beiträge:
    3.391
    Danke erhalten:
    715
    Danke vergeben:
    477
    Den Hinweis zur Antwort auf die Frage, die du nicht gestellt hast, findest du bereits in diesem Thread.
     
  17. Don Alfredo

    Don Alfredo Erfahrener Benutzer

    Registriert seit:
    27. Januar 2012
    Beiträge:
    250
    Danke erhalten:
    5
    Danke vergeben:
    108
    PHP 8.0 mit Version v4.4.0.5 getestet. Weißer Bildschirm, Cache gelöscht, diese bleibt dann leer.
    Im Admin Bereich bleibt der Schirm auch weiß. Auf PhP 7.4 zurück gestellt, Chache füllt sich, Seite erreichbar.
     
  18. daniel_nimmervoll

    Registriert seit:
    30. Mai 2018
    Beiträge:
    19
    Danke erhalten:
    0
    Hallo,
    ich hatte auch gerade testweise auf PHP 8.0 umgestellt. Leider ist der Shop danach nicht mehr erreichbar.
    Habe die Version 4.5.3.1 installiert.
    Wann kommt dafür ein Update?
     
  19. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    30. Oktober 2015
    Beiträge:
    3.391
    Danke erhalten:
    715
    Danke vergeben:
    477
    #19 Anonymous, 17. September 2022
    Zuletzt bearbeitet: 17. September 2022
    @Don Alfredo @daniel_nimmervoll

    Seid ihr nicht in der Lage auf einen oben bereits seit November 2021 stehenden Link zu klicken und hier im Thread nachzulesen?

    Man könnte auch die Suchfunktion benutzen.
    (Link nur für registrierte Nutzer sichtbar.)
     
  20. Don Alfredo

    Don Alfredo Erfahrener Benutzer

    Registriert seit:
    27. Januar 2012
    Beiträge:
    250
    Danke erhalten:
    5
    Danke vergeben:
    108
    Im Link steht die Version GX4 4.7.x.x oder später. Aktuelle Version Master Update v4.6.0.2 (GX4).