Master Update 4.2.0.1 erschienen

Thema wurde von Michael (Gambio), 9. November 2020 erstellt.

  1. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    31.373
    Danke erhalten:
    9.606
    Danke vergeben:
    1.421
    Das müsste es sein:
    Code:
    2020-11-24 15:52:14 ERROR: Error while dispatching event occurred.
    
    context:    
    event:   
    Gambio\Shop\SellingUnit\Database\Unit\Events\OnGetProductInfoEvent
    error:    
    class:   
    TypeError
    message:   
    Return value of product_ORIGIN::getReleaseDate() must be of the type string, null returned
    code:   
    0
    file:   
    /www/htdocs/xxxxx/Testshop/includes/classes/product.php:1310
    extra:    
    request:    
    method:   
    GET
    uri:   
    /shopping_cart.php
    software:   
    Apache
    address:   
    85.13.131.189
    userAgent:   
    Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.67 Safari/537.36 Edg/87.0.664.47
    time:   
    206
    remoteAddress:   
    91.249.62.72
    session:    
    tpl:   
    Malibu
    language:   
    german
    languages_id:   
    2
    language_charset:   
    utf-8
    language_code:   
    de
    currency:   
    EUR
    customers_status:    
    customers_status_id:   
    1
    customers_status_name:   
    Gast
    customers_status_image:   
    guest_status.gif
    customers_status_discount:   
    0.00
    customers_status_public:   
    0
    customers_status_min_order:   
    20
    customers_status_max_order:   
    0
    customers_status_ot_discount_flag:   
    0
    customers_status_ot_discount:   
    0.00
    customers_status_graduated_prices:   
    1
    customers_status_show_price:   
    1
    customers_status_show_price_tax:   
    1
    customers_status_add_tax_ot:   
    0
    customers_status_payment_unallowed:   
    invoice,paypal3
    customers_status_shipping_unallowed:   
    zonese,invoice
    customers_status_discount_attributes:   
    1
    customers_fsk18_purchasable:   
    0
    customers_fsk18_display:   
    1
    customers_status_write_reviews:   
    1
    customers_status_read_reviews:   
    1
    customer_id:   
    payment:   
    shipping:   
    cartID:   
    sendto:   
    billto:   
    
    Ich dachte erst, es liegt daran, dass ich den Warenkorb als Admin gefüllt habe,
    aber wenn ich den Artikel für Gäste sichtbar schalte, funktioniert der Link .
     
  2. barbara

    barbara G-WARD 2014-2020

    Registriert seit:
    14. August 2011
    Beiträge:
    31.373
    Danke erhalten:
    9.606
    Danke vergeben:
    1.421
    Habe hier noch einen etwas anderen Logeintrag:
    Code:
    2020-11-24 16:24:28 ERROR: Uncaught TypeError: Return value of product_ORIGIN::getReleaseDate() must be of the type string, null returned in /www/htdocs/w010a16a/Testshop/includes/classes/product.php:1310
    
    context:    
    message:   
    Uncaught TypeError: Return value of product_ORIGIN::getReleaseDate() must be of the type string, null returned in /www/htdocs/xxx/Testshop/includes/classes/product.php:1310
    Stack trace:
    #0 /www/htdocs/xxx/Testshop/GambioShop/Product/ReleaseDate/Listener/OnGetProductInfoEventListener.php(32): product_ORIGIN->getReleaseDate()
    #1 /www/htdocs/xxx/Testshop/GambioCore/Event/EventDispatcher.php(78): Gambio\Shop\Product\ReleaseDate\Listener\OnGetProductInfoEventListener->__invoke(Object(Gambio\Shop\SellingUnit\Database\Unit\Events\OnGetProductInfoEvent))
    #2 /www/htdocs/xxx/Testshop/GambioShop/SellingUnit/Unit/SellingUnit.php(293): Gambio\Core\Event\EventDispatcher->dispatch(Object(Gambio\Shop\SellingUnit\Database\Unit\Events\OnGetProductInfoEvent))
    #3 /www/htdocs/xxx/Testshop/GXMainComponents/View/ThemeContentViews/shopping_cart/OrderDetailsCartThemeContentView.inc.php(181): Gambio\Shop\SellingUnit\Unit\SellingUnit->productInfo()
    #4 /www/htdocs/xxx/Testshop/GXMainComponents/View/ThemeCon
    code:   
    1
    file:   
    /www/htdocs/xxx/Testshop/includes/classes/product.php
    line:   
    1310
    context:   
    obCleanCache:   
    extra:    
    request:    
    method:   
    GET
    uri:   
    /shopping_cart.php
    software:   
    Apache
    address:   
    85.13.131.189
    userAgent:   
    Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.66 Safari/537.36
    time:   
    121
    remoteAddress:   
    91.249.62.72
    session:    
    tpl:   
    Malibu
    language:   
    german
    languages_id:   
    2
    language_charset:   
    utf-8
    language_code:   
    de
    currency:   
    EUR
    customers_status:    
    ...
    customer_id:   
    payment:   
    shipping:   
    cartID:   
    sendto:   
    billto:   
    
     
  3. Kai Schoelzke

    Kai Schoelzke Beta-Held

    Registriert seit:
    30. März 2016
    Beiträge:
    3.391
    Danke erhalten:
    442
    Danke vergeben:
    151
    #143 Kai Schoelzke, 25. November 2020
    Zuletzt bearbeitet: 27. November 2020
    Wenn man im Artikel die Linke Seitenleiste und den Artikel Navigator aktiviert hat, wird der Inhalt breiter als der Shop.
    Theme: Honeygrid
    Ticket: 101033738
     
  4. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    14. Juni 2018
    Beiträge:
    1.219
    Danke erhalten:
    134
    Danke vergeben:
    747
    Wann können wir den nun mit einer Lösung des Doppelten Bild Laden Bugs rechnen?
     
  5. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.140
    Danke erhalten:
    2.265
    Danke vergeben:
    738
    Das zugrunde liegende Problem ist sehr komplex. Wir arbeiten weiter Vollzeit an dem Fix. Schneller gehts leider nicht.
     
  6. Marvin (Gambio)

    Marvin (Gambio) Moderator
    Mitarbeiter

    Registriert seit:
    5. Februar 2019
    Beiträge:
    51
    Danke erhalten:
    26
    Danke vergeben:
    21
    Dafür habe ich jetzt dieses Ticket angelegt.
     
  7. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    14. Juni 2018
    Beiträge:
    1.219
    Danke erhalten:
    134
    Danke vergeben:
    747
    Wie stehen die Chancen auf einen Fix des Doppelt-Bilder-laden Bug in der nächsten Woche?

    Wir setzen auch das WebP Format aus einem Modul von Herrn Späte ein: Alle Artikel Bilder auf der Produktdetailseite werden jedoch trotzdem in JPEG angezeigt. Alle anderen Bilder (in Beschreibungen, Icons usw.) jedoch korrekt als WebP!
    Auch in der Kategorie Übersicht werden sämtliche Bilder der Artikel im korrekten WebP Format angezeigt. Ich habe die Befürchtung das auch dies den Doppelt Bilder Laden Bug als Ursache hat.
     
  8. Dominik Späte

    Dominik Späte Erfahrener Benutzer

    Registriert seit:
    16. Oktober 2018
    Beiträge:
    163
    Danke erhalten:
    101
    Danke vergeben:
    33
    Auch hier noch einmal vielen lieben Dank und damit ich bei dahingehenden Anfragen an eine zentrale Stelle verweisen kann:

    Zumindest in den bisher von mir geprüften Shops wird das WebP-Bild zunächst korrekt geladen und anschließend durch das Original-Bild (z.B. JPEG) ersetzt, wofür ausschließlich Gambio-Originaldateien sorgen. Einen Fehler im Modul kann ich daher nicht erkennen. An den doppelt ladenden Bildern wird seitens Gambios intensiv gearbeitet.
     
  9. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    14. Juni 2018
    Beiträge:
    1.219
    Danke erhalten:
    134
    Danke vergeben:
    747
    Frischen Testshop installiert zuerst mit Gambio GX4 v4.0.3.0 (Stable).
    = Kein Bilder doppelt laden Bug

    Master Update v4.2.0.1 (GX4) installiert
    = Bilder doppelt laden Bug

    Gambio GX4 v4.3.1.0 (Full)
    = Kein Bilder doppelt laden Bug


    Können wir diese Woche mit dem lang ersehnten Fix rechnen?
     
  10. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    18. Juli 2019
    Beiträge:
    152
    Danke erhalten:
    34
    Danke vergeben:
    4
    Seit ich diese Version installiert habe fängt Google Merchant center an meine Artikel wegen "too many redirects" aus dem Index zu werfen! Was könnte das sein? Es werden immer mehr, mein einstmals guter Rang geht dahin.
     

    Anhänge:

    • mc1.png
      mc1.png
      Dateigröße:
      45,2 KB
      Aufrufe:
      19
  11. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.055
    Danke erhalten:
    6.460
    Danke vergeben:
    1.983
    Öffne deine Feed Datei, nimm einen betroffenen Artikel. Prüf, ob der ohne Redirects aufgerufen werden kann, die URL stimmt.
     
  12. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.140
    Danke erhalten:
    2.265
    Danke vergeben:
    738
    Für die Leute, die auf den "Bilder doppelt laden"-Fix warten: Die Änderungen in dem Fix sind viel umfangreicher, als anfänglich angenommen. Daher konnten wir bisher leider keinen Einzelfix auf die Schnelle zur Verfügung stellen. Die Korrektur wird nun Teil eines Service Pack 4.2.1.0 sein, das, wie immer, als Beta-Version erscheinen wird. Das Service Pack 4.2.1.0 kommt statt einer Korrekturversion 4.2.0.2.
     
  13. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    14. Juni 2018
    Beiträge:
    1.219
    Danke erhalten:
    134
    Danke vergeben:
    747
    Danke das du uns auf dem laufendenhälst. Habt ihr den schon einen groben Termin angeplant? Also...dieses Jahr noch?
     
  14. mmatecki

    mmatecki Erfahrener Benutzer

    Registriert seit:
    24. Juni 2018
    Beiträge:
    404
    Danke erhalten:
    59
    Danke vergeben:
    42
    Hallo Moritz, wann können wir mit dem Pack 4.2.1.0 rechnen und/ oder würde es Sinn machen auf die version 4.3.1.0 umzusteigen?
     
  15. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.055
    Danke erhalten:
    6.460
    Danke vergeben:
    1.983
    Derzeit sieht es nach Ende dieser Woche, Anfang kommender Woche aus. Morgen rückt unsere Kolonne Tester an, die einen Haufen Prüfpunkte bekommen. Je nachdem was dabei rauskommt, ob wir nacharbeiten müssen, wird das Release fallen.
     
  16. Moritz (Gambio)

    Moritz (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    26. April 2011
    Beiträge:
    5.140
    Danke erhalten:
    2.265
    Danke vergeben:
    738
    Die finale Version der 4.2.1.0 kommt noch dieses Jahr, voraussichtlich in KW 51. Euch beiden rate zu dieser Version oder zur 4.3.2.0, die ebenfalls in dem Zeitraum erscheinen wird. 4.3.1.0 hat mittlerweile einige bekannte größere Bugs, so dass sich meiner Meinung nach das Warten auf die neuen Versionen noch lohnt.
     
  17. Wilken (Gambio)

    Wilken (Gambio) Administrator
    Mitarbeiter

    Registriert seit:
    7. November 2012
    Beiträge:
    17.055
    Danke erhalten:
    6.460
    Danke vergeben:
    1.983
    Und für alle die sich jetzt fragen warum 2 Leute 2 Sachen sagen: Ich hab unsere Plan falsch gelesen, mein Fehler.

    Es wird vorab eine Betaversion geben, und ich hab deren Daten benutzt, die kommt entsprechend zeitnah. Die finale Version ist dann üblich entsprechend später, wie Moritz schreibt.
     
  18. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    2. Mai 2017
    Beiträge:
    79
    Danke erhalten:
    20
    Danke vergeben:
    45
    besser nen Tag länger und dafür den "letzten Krümmel" beseitigt
     
  19. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    18. Juli 2019
    Beiträge:
    152
    Danke erhalten:
    34
    Danke vergeben:
    4
    Das habe ich, es gibt keine Weiterleitungen, die URL führt direkt in den Shop. Mit Weiterleitungs-Tool geprüft ("Link redirect trace" Erweiterung für Chrome).

    Dennoch lehnt Google mittlerweile 35% meiner Artikel ab, Tendenz steigend.
    "Fehlende Landingpage, zuviele Redirects" lautet der Fehler.
    Das ist exakt seit Umstieg auf diese Gambio-Version.
    Könnte es sein dass durch die neue .htaccess da etwas verbogen wurde und Google keinen Zugriff mehr auf meine Artikel hat? Ich habe die .htaccess ersetzen lassen und sonst nichts geändert.

    Version:
    SetEnv gambio_htaccessVersion 3.5
    SetEnv gambio_mod_env_working 1


    Hat das noch jemand anders bei sich feststellen können? Im Merchant center kann man das schnell sehen.
     
  20. Anonymous

    Anonymous Erfahrener Benutzer

    Registriert seit:
    15. Mai 2017
    Beiträge:
    302
    Danke erhalten:
    35
    Danke vergeben:
    56
    Wundert mich irgendwie, da es in der 4.2.0.0 wohl nicht drin war und in der 4.3.1.0 ja wohl auch nicht?!?!?!?